summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/libsoup/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/libsoup/PKGBUILD b/extra/libsoup/PKGBUILD
new file mode 100644
index 00000000..cb55527c
--- /dev/null
+++ b/extra/libsoup/PKGBUILD
@@ -0,0 +1,19 @@
+makedepends=(
+ $(
+ printf '%s\n' "${makedepends[@]}" \
+ | grep -vxF gobject-introspection \
+ | grep -vxF vala
+ )
+)
+eval "$(
+ declare -f build \
+ | sed '
+ /arch-meson/ {
+ h
+ s/^/[ "${CARCH}" = i486 ] || /
+ p
+ g
+ s/^.*;$/[ "${CARCH}" != i486 ] || \0 -D vapi=disabled -D introspection=disabled;/
+ }
+ '
+)"