summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/numactl/PKGBUILD3
-rw-r--r--extra/qt5-base/PKGBUILD11
2 files changed, 12 insertions, 2 deletions
diff --git a/extra/numactl/PKGBUILD b/extra/numactl/PKGBUILD
index 54510d20..7364ef5d 100644
--- a/extra/numactl/PKGBUILD
+++ b/extra/numactl/PKGBUILD
@@ -1,6 +1,5 @@
source+=('numactl-2.0.11-minor-major.patch')
-md5sums+=('ef6533742f4392431bccf935626281e5')
-sha1sums+=('791e2fc154bd3d3fa644f00775bef941943a6e59')
+sha256sums+=('952973eb92921a8510d75589c8e69eaace797750f8f011cc2117d482ce0c6367')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index 4613e09b..5459bf68 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -4,3 +4,14 @@ eval "$(
s@./configure@./configure -no-sse2@g
'
)"
+
+makedepends=(${makedepends[@]/vulkan-headers/})
+makedepends_i686=(vulkan-headers)
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@./configure -no-feature-vulkan@g
+ '
+ )"
+fi