summaryrefslogtreecommitdiff
path: root/extra/soundtouch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/soundtouch/PKGBUILD')
-rw-r--r--extra/soundtouch/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/extra/soundtouch/PKGBUILD b/extra/soundtouch/PKGBUILD
new file mode 100644
index 00000000..9c36c6d3
--- /dev/null
+++ b/extra/soundtouch/PKGBUILD
@@ -0,0 +1,18 @@
+# hotfix for changed git repo (already fixed upstream in staging)
+source[0]="git+https://codeberg.org/soundtouch/soundtouch.git#tag=${_tag}"
+
+# configure handles SSE/MMX/etc. but cmake support is somewhat simpler
+# setting flags for disabling optimiazations by hand (and also do the
+# configure stuff, just in case)
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s|./configure|./configure --disable-x86-optimizations|g
+ '
+ declare -f build | \
+ sed '
+ s|cmake |CXXFLAGS=-DSOUNDTOUCH_DISABLE_X86_OPTIMIZATIONS cmake |
+ '
+ )"
+fi