summaryrefslogtreecommitdiff
path: root/extra/rust/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/rust/PKGBUILD')
-rw-r--r--extra/rust/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index b0b2eada..61f33efc 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -1,3 +1,5 @@
+# enable i686-unknown-linux-gnu target
+# and replace pentium4 (SSE2) with pentium3 (no SSE2) in the compiler spec file
source+=(config.toml.patch)
sha256sums+=('55d59786b6a24590951688c01910ac331996fc5ea5e20f10d227db24b93b1e74')
@@ -7,5 +9,6 @@ eval "$(
$ i patch -p1 -i "$srcdir/config.toml.patch"
/}/ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/vendor/rustc-ap-rustc_target/spec/i686_unknown_linux_gnu.rs"
/}/ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/src/librustc_target/spec/i686_unknown_linux_gnu.rs"
+ /}/ i sed -i "s/254a116e0cfbce81d1d38ddd59e1086228332746ae8916647b990dd8226079d3/30594a90c83b496630d0b8d80ce2f93671ab6afedadcdc79afd832f4dfe499fd/g" "$srcdir/rustc-$pkgver-/vendor/rustc-ap-rustc_target/.cargo-checksum.json"
'
)"