summaryrefslogtreecommitdiff
path: root/extra/re2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/re2/PKGBUILD')
-rw-r--r--extra/re2/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/re2/PKGBUILD b/extra/re2/PKGBUILD
new file mode 100644
index 00000000..1cd34742
--- /dev/null
+++ b/extra/re2/PKGBUILD
@@ -0,0 +1,17 @@
+# compiler-test fails in InsufficientMemory test due to the change of
+# the size of the DFA
+# bug: https://github.com/google/re2/issues/256
+# patch: https://github.com/google/re2/commit/bde1ea09550a61b4a092cdf0e3ba8dca4200947a
+source+=('re2-2020-05-01-compile-test-out-of-memory-fix.patch')
+sha256sums+=('bef199b3c77cd6477d9f3950acc5d017ce4a53e447827f01a4706e7e8980b220')
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $ i cd "$pkgname-$_re2ver"; patch -Np1 -i "${srcdir}"/re2-2020-05-01-compile-test-out-of-memory-fix.patch
+ '
+)"
+