summaryrefslogtreecommitdiff
path: root/extra/qt5-declarative/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-declarative/PKGBUILD')
-rw-r--r--extra/qt5-declarative/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/extra/qt5-declarative/PKGBUILD b/extra/qt5-declarative/PKGBUILD
index e7c1c832..387fb122 100644
--- a/extra/qt5-declarative/PKGBUILD
+++ b/extra/qt5-declarative/PKGBUILD
@@ -1,13 +1,12 @@
-# see https://bugreports.qt.io/browse/QTBUG-35430
-# and https://lists.debian.org/debian-qt-kde/2015/10/msg00388.html
-# and https://packages.debian.org/sid/qtdeclarative5-dev
+# disable croaking about missing SSE2 for WASM (web assemblies) when
+# instantiating a Javascript engine
-source+=(Do-not-make-lack-of-SSE2-support-on-x86-32-fatal.patch)
-sha256sums+=('26120747f744571f2ead15c904fcd8d60e0c94fb538c711ae6051ab02d418e0d')
+source+=(qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch)
+sha256sums+=('5dce1799db9c4bca10006eb4a4980ffa74d6da5b18ab02f31a5267c44338b765')
eval "$(
declare -f prepare | \
sed '
- /cd/a if [ "${CARCH}" != "pentium4" ]; then patch -Np1 -i ../Do-not-make-lack-of-SSE2-support-on-x86-32-fatal.patch; fi
+ /cd/a if [ "${CARCH}" != "pentium4" ]; then patch -Np1 -i ../qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch; fi
'
)"