summaryrefslogtreecommitdiff
path: root/extra/qt5-base/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-base/PKGBUILD')
-rw-r--r--extra/qt5-base/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index 0f8c26cb..1a79f2de 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -28,3 +28,15 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+# -no-ltcg is partially ignored, patching it directly in the mkspecs
+source+=('qtbase-no-ltcg-broken.patch')
+sha256sums+=('024549dbb8cc76921c16070b4cf1253e88fd33f78d6756e2ee398c405b8d1979')
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ $ i \
+ patch -p1 < ../qtbase-no-ltcg-broken.patch
+ '
+ )"
+fi