summaryrefslogtreecommitdiff
path: root/extra/qt5-base/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-base/PKGBUILD')
-rw-r--r--extra/qt5-base/PKGBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index ac9aecb9..1a79f2de 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -7,25 +7,36 @@ if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
)"
fi
-makedepends=(${makedepends[@]/vulkan-headers/})
-makedepends_i686+=(vulkan-headers)
-makedepends_pentium4=("${makedepends_i686[@]}")
+# enable XCB explicitely for now on i486 (rather fail early than to
+# get weird startup messages of Qt5 applications hours later)
if [ "$CARCH" = 'i486' ]; then
eval "$(
declare -f build | \
sed '
- s@./configure@./configure -no-feature-vulkan@g
+ s/configure/configure -xcb /
'
- )"
+ )"
fi
-ic issues on i486
+# no LTO on 486 slaves, they die with out-of-memory
if [ "$CARCH" = 'i486' ]; then
- makedepends=(${makedepends[@]//mariadb-libs/})
eval "$(
declare -f build | \
sed '
- /-plugin-sql-/s/mysql,//
+ s/-ltcg/-no-ltcg/
+ s/\(.*qmake *\)CONFIG+=fat-static-lto\(.*\)/\1 \2/
'
)"
fi
+# -no-ltcg is partially ignored, patching it directly in the mkspecs
+source+=('qtbase-no-ltcg-broken.patch')
+sha256sums+=('024549dbb8cc76921c16070b4cf1253e88fd33f78d6756e2ee398c405b8d1979')
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ $ i \
+ patch -p1 < ../qtbase-no-ltcg-broken.patch
+ '
+ )"
+fi