summaryrefslogtreecommitdiff
path: root/extra/qt5-base/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-base/PKGBUILD')
-rw-r--r--extra/qt5-base/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index a5a0a8e6..1a79f2de 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -17,3 +17,26 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# no LTO on 486 slaves, they die with out-of-memory
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-ltcg/-no-ltcg/
+ s/\(.*qmake *\)CONFIG+=fat-static-lto\(.*\)/\1 \2/
+ '
+ )"
+fi
+# -no-ltcg is partially ignored, patching it directly in the mkspecs
+source+=('qtbase-no-ltcg-broken.patch')
+sha256sums+=('024549dbb8cc76921c16070b4cf1253e88fd33f78d6756e2ee398c405b8d1979')
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ $ i \
+ patch -p1 < ../qtbase-no-ltcg-broken.patch
+ '
+ )"
+fi