summaryrefslogtreecommitdiff
path: root/extra/python-urllib3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-urllib3/PKGBUILD')
-rw-r--r--extra/python-urllib3/PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/extra/python-urllib3/PKGBUILD b/extra/python-urllib3/PKGBUILD
index d7d670d3..ab31fc8d 100644
--- a/extra/python-urllib3/PKGBUILD
+++ b/extra/python-urllib3/PKGBUILD
@@ -10,3 +10,19 @@ eval "$(
s/python setup.py pytest/python setup.py pytest || true/
'
)"
+
+# breaking the cycle with python-spinx
+makedepends=(${makedepends[@]/python-sphinx-furo})
+makedepends=(${makedepends[@]/python-sphinx})
+eval "$(
+ declare -f build | \
+ sed '
+ /make html/d
+ '
+)"
+eval "$(
+ declare -f package_python-urllib3-doc | \
+ sed '
+ /cp.*_build\/html/d
+ '
+)"