summaryrefslogtreecommitdiff
path: root/extra/python-setuptools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-setuptools/PKGBUILD')
-rw-r--r--extra/python-setuptools/PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
index 3dfb6ab0..2b768f5c 100644
--- a/extra/python-setuptools/PKGBUILD
+++ b/extra/python-setuptools/PKGBUILD
@@ -1,2 +1,15 @@
-# temporary during bootstrap
-unset check
+# create directory before installing (otherwise installing fails)
+eval "$(
+ declare -f package | \
+ sed '
+ 4 i mkdir build/scripts-3.10
+ '
+)"
+
+# ignore errors in tests, but execute the tests
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(python.*\)/\1 || true/
+ '
+)"