summaryrefslogtreecommitdiff
path: root/extra/python-numpy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-numpy/PKGBUILD')
-rw-r--r--extra/python-numpy/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/python-numpy/PKGBUILD b/extra/python-numpy/PKGBUILD
new file mode 100644
index 00000000..6e15ddae
--- /dev/null
+++ b/extra/python-numpy/PKGBUILD
@@ -0,0 +1,17 @@
+# enable SSE/SSE2 on pentium4, no optimizations on i686 and i486
+if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|python setup.py build|python setup.py build --cpu-baseline=NONE --cpu-dispatch=NONE|
+ '
+ )"
+fi
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|python setup.py build|python setup.py build --cpu-baseline=NONE --cpu-dispatch=SSE,SSE2|
+ '
+ )"
+fi