summaryrefslogtreecommitdiff
path: root/extra/opencolorio
diff options
context:
space:
mode:
Diffstat (limited to 'extra/opencolorio')
-rw-r--r--extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch12
-rw-r--r--extra/opencolorio/PKGBUILD16
2 files changed, 28 insertions, 0 deletions
diff --git a/extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch b/extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch
new file mode 100644
index 00000000..f6ad78c1
--- /dev/null
+++ b/extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch
@@ -0,0 +1,12 @@
+diff -rauN OpenColorIO-2.1.1/share/cmake/utils/CompilerFlags.cmake OpenColorIO-2.1.1-no-sse2-patch/share/cmake/utils/CompilerFlags.cmake
+--- OpenColorIO-2.1.1/share/cmake/utils/CompilerFlags.cmake 2021-12-16 20:19:03.000000000 +0100
++++ OpenColorIO-2.1.1-no-sse2-patch/share/cmake/utils/CompilerFlags.cmake 2022-04-02 11:24:18.450648391 +0200
+@@ -86,7 +86,7 @@
+ ###############################################################################
+ # Define if SSE2 can be used.
+
+-include(CheckSupportSSE2)
++#include(CheckSupportSSE2)
+
+ if(NOT HAVE_SSE2)
+ message(STATUS "Disabling SSE optimizations, as the target doesn't support them")
diff --git a/extra/opencolorio/PKGBUILD b/extra/opencolorio/PKGBUILD
new file mode 100644
index 00000000..7d8f94cf
--- /dev/null
+++ b/extra/opencolorio/PKGBUILD
@@ -0,0 +1,16 @@
+# Disable SSE2 in the cmake probing (we cannot set it from outside, so
+# cross-compilation or building in a chrooted environment fails)
+source+=('OpenColorIO-2.1.1-no-sse2.patch')
+sha512sums+=('8055b90d387e2cd674a25344b520d093ef8f761f294a77c71694f7ba93806a58350140b7e373e91432d555def5addd35fad4aca59518aab12b56c5b6106c4352')
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
+ eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/OpenColorIO-$pkgver" \
+ patch -Np1 -i "$srcdir/OpenColorIO-2.1.1-no-sse2.patch"
+ '
+ )"
+fi