summaryrefslogtreecommitdiff
path: root/extra/mpd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mpd/PKGBUILD')
-rw-r--r--extra/mpd/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/mpd/PKGBUILD b/extra/mpd/PKGBUILD
index f05a66ec..8b3eca20 100644
--- a/extra/mpd/PKGBUILD
+++ b/extra/mpd/PKGBUILD
@@ -7,3 +7,14 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# disabling LTO on i486
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /local _meson_options.*/ a \
+ _meson_options+=(-Db_lto=false)
+ '
+ )"
+fi