summaryrefslogtreecommitdiff
path: root/extra/mpd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mpd/PKGBUILD')
-rw-r--r--extra/mpd/PKGBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/extra/mpd/PKGBUILD b/extra/mpd/PKGBUILD
index 93b81cfd..8b3eca20 100644
--- a/extra/mpd/PKGBUILD
+++ b/extra/mpd/PKGBUILD
@@ -3,7 +3,18 @@ if [ "$CARCH" = 'i486' ]; then
eval "$(
declare -f build | \
sed '
- /meson/ i LDFLAGS=-latomic
+ /meson/ i LDFLAGS+=" -latomic"
'
)"
fi
+
+# disabling LTO on i486
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /local _meson_options.*/ a \
+ _meson_options+=(-Db_lto=false)
+ '
+ )"
+fi