summaryrefslogtreecommitdiff
path: root/extra/mono/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mono/PKGBUILD')
-rw-r--r--extra/mono/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/extra/mono/PKGBUILD b/extra/mono/PKGBUILD
new file mode 100644
index 00000000..7cf3826b
--- /dev/null
+++ b/extra/mono/PKGBUILD
@@ -0,0 +1,15 @@
+if [ "$CARCH" = 'i486' ]; then
+ # these atomics are unavailable on i486, but that is not detected (?)
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /^}$/ i \
+ sed -i '"'"' \
+ /#define BROKEN_64BIT_ATOMICS_INTRINSIC 1/ { \
+ N \
+ s/\\(.*\\)\\n\\s*#endif/#endif\\n\\1/ \
+ } \
+ '"'"' mono/utils/atomic.h
+ '
+ )"
+fi