summaryrefslogtreecommitdiff
path: root/extra/meson/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/meson/PKGBUILD')
-rw-r--r--extra/meson/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index 0f009bb1..376dd629 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -16,3 +16,12 @@ checkdepends_pentium4=("${checkdepends_i686[@]}")
# still far too many tests fail, ignoring for now
unset check
unset checkdepends
+
+# fail if upstream changes arch-meson
+# we patch a version of arch-meson reading CARCH (later maybe LTOFLAGS)
+# to find out whether it should add blto to the arch flags
+for ((i=0; i<${#sha512sums[@]}; i++)); do
+ if [ "${sha512sums[${i}]}" = 'f451f8a7ef9cf1dd724c2ce20bb85a3f1611b87b2e7a17ef0fdbe8ab82a67389f818ea30a5adfe8413143e4eac77ea2e0b8234b5b2466b41a892e2bd0435376c' ]; then
+ sha512sums[${i}]='4b389796c52a5aa84a05cecc9b0c87924992627a61faf1707624f157d03315df143a562bec982d3ad7c64a7de767fce56567e718005cb92e297672d37b39230e'
+ fi
+done