summaryrefslogtreecommitdiff
path: root/extra/libsoup3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libsoup3/PKGBUILD')
-rw-r--r--extra/libsoup3/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/extra/libsoup3/PKGBUILD b/extra/libsoup3/PKGBUILD
index 5d1f8d5d..2b2ec219 100644
--- a/extra/libsoup3/PKGBUILD
+++ b/extra/libsoup3/PKGBUILD
@@ -5,3 +5,15 @@ eval "$(
s/\(meson test.*\)/\1 || true/
'
)"
+
+# disable Vala for now on i486 (fails to build)
+# also disable documentation with too many dependencies
+if [ "${CARCH}" = "i486" ]; then
+ makedepends=(${makedepends[@]//vala/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-D gtk_doc=true/-D gtk_doc=false -Dvapi=disabled/
+ '
+ )"
+fi