summaryrefslogtreecommitdiff
path: root/extra/libsoup/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libsoup/PKGBUILD')
-rw-r--r--extra/libsoup/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/libsoup/PKGBUILD b/extra/libsoup/PKGBUILD
index 004d1729..f1f66c6a 100644
--- a/extra/libsoup/PKGBUILD
+++ b/extra/libsoup/PKGBUILD
@@ -1,3 +1,4 @@
+# remove Vala and introspection on i486
for _drop_dep in gobject-introspection vala; do
if makedepends_i686+=(
$(
@@ -26,3 +27,13 @@ eval "$(
}
'
)"
+
+# remove dependency on sysprof
+depends=(${depends[@]//sysprof/})
+makedepends=(${makedepends[@]//sysprof/})
+eval "$(
+ declare -f build | \
+ sed '
+ s@arch-meson@arch-meson -D sysprof=disabled@g
+ '
+)"