summaryrefslogtreecommitdiff
path: root/extra/libinput/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libinput/PKGBUILD')
-rw-r--r--extra/libinput/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/libinput/PKGBUILD b/extra/libinput/PKGBUILD
new file mode 100644
index 00000000..d4a9f2b4
--- /dev/null
+++ b/extra/libinput/PKGBUILD
@@ -0,0 +1,10 @@
+# break cycle with gtk3+
+if [ "${CARCH}" = "i486" ]; then
+ makedepends=(${makedepends[@]//gtk3/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /arch-meson/s/build/build -Ddebug-gui=false/
+ '
+ )"
+fi