summaryrefslogtreecommitdiff
path: root/extra/libinput/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libinput/PKGBUILD')
-rw-r--r--extra/libinput/PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/extra/libinput/PKGBUILD b/extra/libinput/PKGBUILD
index d4a9f2b4..a389b314 100644
--- a/extra/libinput/PKGBUILD
+++ b/extra/libinput/PKGBUILD
@@ -1,10 +1,5 @@
-# break cycle with gtk3+
-if [ "${CARCH}" = "i486" ]; then
- makedepends=(${makedepends[@]//gtk3/})
- eval "$(
- declare -f build | \
- sed '
- /arch-meson/s/build/build -Ddebug-gui=false/
- '
- )"
+# fails to rebuild currently on i486
+# /usr/bin/ld: warning: libicui18n.so.69, needed by /usr/lib//libtracker-sparql-3.0.so.0, not found (try using -rpath or -rpath-link)
+if [ "$CARCH" == 'i486' ]; then
+ makedepends+=(icu69)
fi