summaryrefslogtreecommitdiff
path: root/extra/libcuckoo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libcuckoo/PKGBUILD')
-rw-r--r--extra/libcuckoo/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/extra/libcuckoo/PKGBUILD b/extra/libcuckoo/PKGBUILD
new file mode 100644
index 00000000..ffda60f6
--- /dev/null
+++ b/extra/libcuckoo/PKGBUILD
@@ -0,0 +1,23 @@
+# fix tests with https://github.com/efficient/libcuckoo/commit/c749c88864d286c3d875b1de2a082355b7838af7,
+# see https://github.com/efficient/libcuckoo/issues/137
+source+=('libcuckoo-0.3-resize-unit-test.patch')
+md5sums+=('653038be4849c29e459e946ce0cbdac6')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd "${pkgname}-${pkgver}"\n}\n'
+ } \
+ | sed '
+ $ i patch -Np1 -i "$srcdir/libcuckoo-0.3-resize-unit-test.patch"
+ '
+)"
+
+# i486 needs -latomic
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DCMAKE_CXX_STANDARD_LIBRARIES=-latomic /
+ '
+ )"
+fi