summaryrefslogtreecommitdiff
path: root/extra/ibus/ibus-novala.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/ibus/ibus-novala.patch')
-rw-r--r--extra/ibus/ibus-novala.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/extra/ibus/ibus-novala.patch b/extra/ibus/ibus-novala.patch
new file mode 100644
index 00000000..0619f02b
--- /dev/null
+++ b/extra/ibus/ibus-novala.patch
@@ -0,0 +1,53 @@
+diff -rauN ibus/configure.ac ibus-novala-patch/configure.ac
+--- ibus/configure.ac 2021-04-10 10:53:19.694774398 +0200
++++ ibus-novala-patch/configure.ac 2021-04-10 10:54:26.574743698 +0200
+@@ -611,6 +611,18 @@
+ enable_engine="yes (enabled, use --disable-engine to disable)"
+ fi
+
++# --disable-tools
++AC_ARG_ENABLE(tools,
++ AS_HELP_STRING([--disable-tools],
++ [Disable tools]),
++ [enable_tools=$enableval],
++ [enable_tools=yes]
++)
++AM_CONDITIONAL([ENABLE_TOOLS], [test x"$enable_tools" = x"yes"])
++if test x"$enable_tools" = x"yes"; then
++ enable_tools="yes (enabled, use --disable-tools to disable)"
++fi
++
+ PKG_CHECK_MODULES(XTEST,
+ [x11 xtst],
+ [enable_xtest=yes],
+@@ -833,6 +845,7 @@
+ Build document $enable_gtk_doc
+ Build UI $enable_ui
+ Build engine $enable_engine
++ Build tools $enable_tools
+ Enable key snooper $enable_key_snooper
+ No snooper regexes "$NO_SNOOPER_APPS"
+ Panel icon "$IBUS_ICON_KEYBOARD"
+diff -rauN ibus/Makefile.am ibus-novala-patch/Makefile.am
+--- ibus/Makefile.am 2021-04-10 10:53:19.688107734 +0200
++++ ibus-novala-patch/Makefile.am 2021-04-10 10:54:21.234746577 +0200
+@@ -31,6 +31,10 @@
+ ENGINE_DIR = engine
+ endif
+
++if ENABLE_TOOLS
++TOOLS_DIR = tools
++endif
++
+ if ENABLE_SETUP
+ SETUP_DIR = setup
+ endif
+@@ -58,7 +62,7 @@
+ docs \
+ $(ENGINE_DIR) \
+ $(UI_DIR) \
+- tools \
++ $(TOOLS_DIR) \
+ $(DAEMON_DIR) \
+ $(PYTHON_LIB_DIRS) \
+ $(SETUP_DIR) \