summaryrefslogtreecommitdiff
path: root/extra/ibus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/ibus/PKGBUILD')
-rw-r--r--extra/ibus/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/extra/ibus/PKGBUILD b/extra/ibus/PKGBUILD
new file mode 100644
index 00000000..f533da4a
--- /dev/null
+++ b/extra/ibus/PKGBUILD
@@ -0,0 +1,27 @@
+# break cycle with Qt, gtk3 on i486
+# Vala is not bootstrapped on i486
+# disable wayland for now
+if [ "$CARCH" = 'i486' ]; then
+ depends=(${depends[@]//gtk3/})
+ makedepends=(${makedepends[@]//qt5-base/})
+ makedepends=(${makedepends[@]//vala/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@./configure --disable-gtk3 --enable-vala=no --disable-engine --disable-tools@
+ s@--enable-wayland@--disable-wayland@
+ '
+ )"
+
+ # some parts of the engine and the tools still require Vala
+ source+=('ibus-novala.patch')
+ sha512sums+=('4618394f118e67e340831beb71929bed06be4335d2e0e8ce9793459cf19b0bf0255f7757471433036a362b8beb63f12e79832e40b98435e4209bbe04d590b070')
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /cd/ a \
+ patch -Np1 -i "$srcdir/ibus-novala.patch"
+ '
+ )"
+fi