summaryrefslogtreecommitdiff
path: root/extra/gtk4/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/gtk4/PKGBUILD')
-rw-r--r--extra/gtk4/PKGBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/extra/gtk4/PKGBUILD b/extra/gtk4/PKGBUILD
index a93cbef4..38ac8537 100644
--- a/extra/gtk4/PKGBUILD
+++ b/extra/gtk4/PKGBUILD
@@ -22,21 +22,8 @@ eval "$(
'
)"
-# Vala is not bootstrapped on i486
-# (thus no tracker3)
-# gst-plugins-bad-libs have too many dependencies not available yet on i486
-# gstreamer not built on i486 for now (circular dependency?)
-# adwaita-icon-theme is in a cycle with gtk-update-icon-cache (which we
-# build here in gtk4)
-if [ "$CARCH" = 'i486' ]; then
- depends=(${depends[@]//tracker3/})
- depends=(${depends[@]//gst-plugins-bad-libs/})
- depends=(${depends[@]//adwaita-icon-theme/})
- eval "$(
- declare -f build | \
- sed '
- s/-D tracker=enabled/-D tracker=disabled/
- s/arch-meson/arch-meson -D media-gstreamer=disabled/
- '
- )"
+# temporarily we depend on old sparql versions, which require older
+# versions of icu
+if [ "${CARCH}" = 'i486' ]; then
+ makedepends+=(icu70 icu69)
fi