summaryrefslogtreecommitdiff
path: root/extra/flac/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/flac/PKGBUILD')
-rw-r--r--extra/flac/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/extra/flac/PKGBUILD b/extra/flac/PKGBUILD
new file mode 100644
index 00000000..c266c030
--- /dev/null
+++ b/extra/flac/PKGBUILD
@@ -0,0 +1,25 @@
+# See http://lists.xiph.org/pipermail/flac-dev/2022-March/006514.html
+# -mstackrealign gets also added to nasm compilation, which results in 'no such option'
+# See also FS32#242
+source+=('flac-1.3.4-no-mstackrealign-for-nasm.patch')
+sha512sums+=('88c8f12321f1a16d5fa742ce66f84c31a1fec5a5095355bece314fe3aca8e35bccbf112762e719148af58c65a968d6c0060d93d6371b84d1b853a2d6eadc15c0')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname-$pkgver" \
+ patch -Np1 -i "$srcdir/flac-1.3.4-no-mstackrealign-for-nasm.patch"
+ '
+)"
+
+# disable SSE on i686 and i486
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/cmake -S/cmake -DWITH_SSE=OFF -S/
+ '
+ )"
+fi