summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD2
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch14
2 files changed, 10 insertions, 6 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index e20df7ea..11d9d040 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -96,7 +96,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('2cf35cc22b4a9bccfaca403abed5621d666a5d6d3c87774b3f151265c6d6e090')
+sha256sums+=('4da71f6614dce71db8e9ec2d317514aae90838c2c65620d435f0df06b45b578b')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 4d6c9ee6..f5e0f6a0 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,11 +1,12 @@
-diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
---- a/config/makefiles/rust.mk 2019-12-02 13:22:52.000000000 +0100
-+++ b/config/makefiles/rust.mk 2019-12-14 11:02:19.896773114 +0100
-@@ -265,15 +265,15 @@
+diff -rauN firefox-72.0.1/config/makefiles/rust.mk firefox-72.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk
+--- firefox-72.0.1/config/makefiles/rust.mk 2020-01-08 02:23:30.000000000 +0100
++++ firefox-72.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-01-10 12:17:40.172666172 +0100
+@@ -292,17 +292,17 @@
# the chance of proxy bypasses originating from rust code.
# The check only works when rust code is built with -Clto.
- # Enabling sancov also causes this to fail.
+ # Enabling sancov or TSan also causes this to fail.
-ifndef MOZ_PROFILE_GENERATE
+-ifndef MOZ_TSAN
-ifeq ($(OS_ARCH), Linux)
-ifeq (,$(rustflags_sancov))
-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
@@ -14,7 +15,9 @@ diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
-endif
-endif
-endif
+-endif
+#ifndef MOZ_PROFILE_GENERATE
++#ifndef MOZ_TSAN
+#ifeq ($(OS_ARCH), Linux)
+#ifeq (,$(rustflags_sancov))
+#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
@@ -23,6 +26,7 @@ diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+#endif
+#endif
+#endif
++#endif
force-cargo-library-check:
$(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)