summaryrefslogtreecommitdiff
path: root/extra/cmake/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/cmake/PKGBUILD')
-rw-r--r--extra/cmake/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/extra/cmake/PKGBUILD b/extra/cmake/PKGBUILD
new file mode 100644
index 00000000..6683520d
--- /dev/null
+++ b/extra/cmake/PKGBUILD
@@ -0,0 +1,18 @@
+# do not build in parallel on build slaves
+eval "$(
+ declare -f build | \
+ sed '
+ s/--parallel=.*/--parallel=1/
+ '
+)"
+
+# ignore gui on i486 (for now, needs Qt6, which needs atomics)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//qt6-base/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--qt-gui//
+ '
+ )"
+fi