summaryrefslogtreecommitdiff
path: root/extra/babl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/babl/PKGBUILD')
-rw-r--r--extra/babl/PKGBUILD33
1 files changed, 31 insertions, 2 deletions
diff --git a/extra/babl/PKGBUILD b/extra/babl/PKGBUILD
index 8569425e..f7ae127c 100644
--- a/extra/babl/PKGBUILD
+++ b/extra/babl/PKGBUILD
@@ -1,9 +1,38 @@
+# disable SSE4, AVX2, f16c on 486, 686, pentium4
+eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Denable-sse4_1=false -Denable=avx2=false -Denable-f16c=false /g
+ '
+)"
+
# disable SSE2 on 486 and 686
-if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
eval "$(
declare -f build | \
sed '
- s/configure/configure --disable-sse2/
+ s/arch-meson /arch-meson -Denable-sse2=false /g
'
)"
fi
+
+# disable all SIMD optimizations on 486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Denable-sse=false /g
+ '
+ )"
+fi
+
+# workaround for FS#71143
+makedepends+=(openssh)
+
+# documentation build fails
+eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Dwith-docs=false /g
+ '
+)"