summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/binutils/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index 047cfc82..7759d24b 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -63,3 +63,15 @@ eval "$(
s/ check/ check || true/
'
)"
+
+# solve hen and egg issues around libiberty conflicts
+# (they are part of gcc at the moment, after breaking the
+# cycle we must readd them!)
+eval "$(
+ declare -f package | \
+ sed '
+ /rm.*opcodes/ a \
+ rm -f "$pkgdir"/usr/include/libiberty \
+ rm -f "$pkgdir"/usr/lib/libiberty.a
+ '
+)"