summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-02-17 21:27:38 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-02-17 21:27:38 +0100
commit0d1701601b0a97cd2a7f5d05f2b4e2044afe337c (patch)
tree9f555b7617e91f776f716a06e44c5328e80c17fa /core
parent09c21f248edb3cab66341c171191e328544d87e1 (diff)
downloadpackages-0d1701601b0a97cd2a7f5d05f2b4e2044afe337c.tar.xz
core/binutils: break libiberty cycle with gcc
Diffstat (limited to 'core')
-rw-r--r--core/binutils/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index 047cfc82..7759d24b 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -63,3 +63,15 @@ eval "$(
s/ check/ check || true/
'
)"
+
+# solve hen and egg issues around libiberty conflicts
+# (they are part of gcc at the moment, after breaking the
+# cycle we must readd them!)
+eval "$(
+ declare -f package | \
+ sed '
+ /rm.*opcodes/ a \
+ rm -f "$pkgdir"/usr/include/libiberty \
+ rm -f "$pkgdir"/usr/lib/libiberty.a
+ '
+)"