summaryrefslogtreecommitdiff
path: root/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
diff options
context:
space:
mode:
Diffstat (limited to 'core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch')
-rw-r--r--core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch b/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
new file mode 100644
index 00000000..12607f2a
--- /dev/null
+++ b/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
@@ -0,0 +1,26 @@
+diff --git a/meson.build b/meson.build
+index 88a470a..1d864e3 100644
+--- a/meson.build
++++ b/meson.build
+@@ -765,7 +765,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
+
+ enable_debug_hashmap = false
+ enable_debug_mmap_cache = false
+-foreach name : get_option('debug')
++foreach name : get_option('debug-extra')
+ if name == 'hashmap'
+ enable_debug_hashmap = true
+ elif name == 'mmap-cache'
+diff --git a/meson_options.txt b/meson_options.txt
+index 16c1f2b..dc7951b 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -46,7 +46,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
+ description : 'path to debug shell binary')
+ option('debug-tty', type : 'string', value : '/dev/tty9',
+ description : 'specify the tty device for debug shell')
+-option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
++option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
+ description : 'enable extra debugging')
+ option('memory-accounting-default', type : 'boolean',
+ description : 'enable MemoryAccounting= by default')