summaryrefslogtreecommitdiff
path: root/core/systemd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/systemd/PKGBUILD')
-rw-r--r--core/systemd/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 02cee487..a7e5ae15 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -7,3 +7,14 @@ eval "$(
/patch.*0001.*/a patch -Np1 -i ../meson-rename-Ddebug-to-Ddebug-extra.patch
'
)"
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # temporary, as there is no systemd-journal user for some reason!?
+ eval "$(
+ declare -f package_systemd | \
+ sed '
+ /install.*systemd-journal/d
+ '
+ )"
+fi