summaryrefslogtreecommitdiff
path: root/core/systemd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/systemd/PKGBUILD')
-rw-r--r--core/systemd/PKGBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index baf567fc..be057de8 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -1,23 +1,11 @@
-source+=('meson-rename-Ddebug-to-Ddebug-extra.patch')
-sha512sums+=('d310e7ea099bd371eb12fb4f474f1518ddc1013612d6a53c3f5777e6a3509eb58c4b5989d31bb04784be70db5d8ca39bff47414456c3fe322194cd7b341ae70c')
+# LZ4 test fails, see upstream FS#60239
+
+source+=(lz4-test-compress-partial.patch)
+sha512sums+=('afc199c8d091c1b87fa0719b82bb29ff32595d51034127d1a8c7f83f539f52d0d8a4fa90cf22e286bf3e9104603ecfc9275c3527b9adc2d05d9bcb9234e3c208')
eval "$(
declare -f prepare | \
sed '
- /patch.*0001.*/a patch -Np1 -i ../meson-rename-Ddebug-to-Ddebug-extra.patch
+ /patch.*/a patch -Np1 -i ../lz4-test-compress-partial.patch
'
)"
-
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
- # temporary, as there is no systemd-journal user for some reason!?
- eval "$(
- declare -f package_systemd | \
- sed '
- /install.*systemd-journal/d
- '
- )"
-
- # tempoary failure, known upstream, see FS#60239
- unset check
-fi