summaryrefslogtreecommitdiff
path: root/core/syslinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/syslinux/PKGBUILD')
-rw-r--r--core/syslinux/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/core/syslinux/PKGBUILD b/core/syslinux/PKGBUILD
index 410b180a..16d4f937 100644
--- a/core/syslinux/PKGBUILD
+++ b/core/syslinux/PKGBUILD
@@ -11,3 +11,15 @@ eval "$(
'
)"
+# binutils adds a nore.gnu.proprerty ELF section, this makes the MBR slightly
+# too big to fit on disk (see also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906414)
+
+source+=(syslinux-strip-gnu-property.patch)
+sha1sums+=('fb8e96b559516038e628ad55e0331e4c668205a8')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*efi_no_kbd/a patch -p1 < ../syslinux-strip-gnu-property.patch
+ '
+)"