summaryrefslogtreecommitdiff
path: root/core/python/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/python/PKGBUILD')
-rw-r--r--core/python/PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/core/python/PKGBUILD b/core/python/PKGBUILD
index 1880d300..aa4a7b5e 100644
--- a/core/python/PKGBUILD
+++ b/core/python/PKGBUILD
@@ -44,10 +44,22 @@ fi
# test_gdb currently fails for unknown reasons, also not that important
# test_socket tests take more than 1.5 hours, so ignoring them
# Ignore test_cmath test_math test_turtle - they fail due to too low precision
-# on i686 (all of them - really? - actually, I just checket test_cmath)
+# on i686 (all of them - really? - actually, I just checket test_cmath),
+# test_multiprocessing_forkserver, test_concurrent_futures, test_compileall
+# all hang at least on i486
eval "$(
declare -f check | \
sed "
- /-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle \\|\\| true/g
+ /-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle -x test_multiprocessing_forkserver -x test_concurrent_futures -x test_compileall \\|\\| true/g
"
)"
+
+# no LTO on 486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--with-lto/--without-lto/
+ '
+ )"
+fi