summaryrefslogtreecommitdiff
path: root/core/pacman/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/pacman/PKGBUILD')
-rw-r--r--core/pacman/PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 23c625a8..e7e5974b 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -1,11 +1,11 @@
-# upstream git revision: fb2af6c105822feb0e5e097d25cc2816416bb294
+# upstream git revision: 557099dcb495b55b563735a21fdc393d0fc050fb
depends+=(archlinux32-keyring)
# fail if upstream changes makepkg.conf or pacman.conf
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '89d1dd7e7064243754efc1993a8843a400afd5d7c15070787985376ec346d6d9' ]; then
- sha256sums[${i}]='79c5cb75d53a957db9dcc4605a3aa7cefa27915992267bee1f5747264ac1359d'
+ if [ "${sha256sums[${i}]}" = '072020e34f2c55b94a9a486829a7eadab0a830ddb4d8e759b0c4e6cf1bde73a6' ]; then
+ sha256sums[${i}]='2ad58ba534fed9d728d273c7b5920a495c15cfb58b5c3864bfa023a939abc5d0'
fi
if [ "${sha256sums[${i}]}" = '606e55f06c297d2b508bc4438890b229a1abaa68b0374a2d7f94c8e7be6792d7' ]; then
sha256sums[${i}]='fa05e6f8a83f09fc347988a8ad9dce6fad50d542b2d77fc07fd1b604309990be'
@@ -23,6 +23,7 @@ if [ ! "${CARCH}" = "i686" ]; then
)"
fi
+# patch pacman for automatic architecture detection
source+=('replace-i686-by-pentium4-when-architecture-is-auto.patch')
sha256sums+=('6a7906bd28a57cbcff58d856ffefbbb9096a163aaff79913b4fac69d75d0028a')
@@ -37,10 +38,17 @@ eval "$(
'
)"
-# FAIL: test 600 (also 64-bit), ignore for now
-eval "$(
- declare -f check | \
- sed '
- s/make\(.*\)check/make \1 check || true/
+# not supported on i486 -fcf-protection
+# LTO currently no availavle on i486
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ {
+ declare -f package || \
+ printf 'package() {\n}\n'
+ } \
+ | sed '
+ $i sed -i "s/-fcf-protection//g" "$pkgdir/etc/makepkg.conf"
+ $i sed -i "s/LTOFLAGS.*/LTOFLAGS=\\\"-fno-lto\\\"/" "$pkgdir/etc/makepkg.conf"
'
-)"
+ )"
+fi