summaryrefslogtreecommitdiff
path: root/core/openssh
diff options
context:
space:
mode:
Diffstat (limited to 'core/openssh')
-rw-r--r--core/openssh/PKGBUILD13
-rw-r--r--core/openssh/openssh-8.4p1-sandbox-seccomp-pselect6_time64.patch13
2 files changed, 26 insertions, 0 deletions
diff --git a/core/openssh/PKGBUILD b/core/openssh/PKGBUILD
new file mode 100644
index 00000000..53f6131a
--- /dev/null
+++ b/core/openssh/PKGBUILD
@@ -0,0 +1,13 @@
+# T2SDE patch for missing pselect6_time64 in seccomp, thanks :-)
+source+=(openssh-8.4p1-sandbox-seccomp-pselect6_time64.patch)
+sha1sums+=(9e012cadce997527a8bb305b31ee08e099659049)
+sha256sums+=(db7c0acfbed11ce4c2dbc602e8d5dfb8d46428679e96b325f564932ac2d8e14e)
+b2sums+=(8fb53eaeb1b4fde0ce8713ceb261c71ab88fa9eba4e89f080d2cda1f625b5cbd4d67f3d51decd8c043469346f2ae7259f8a9a67c480ee0114f43a102054a3115)
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*001/ a \
+ patch -p1 -i ../openssh-8.4p1-sandbox-seccomp-pselect6_time64.patch
+ '
+)"
diff --git a/core/openssh/openssh-8.4p1-sandbox-seccomp-pselect6_time64.patch b/core/openssh/openssh-8.4p1-sandbox-seccomp-pselect6_time64.patch
new file mode 100644
index 00000000..94776548
--- /dev/null
+++ b/core/openssh/openssh-8.4p1-sandbox-seccomp-pselect6_time64.patch
@@ -0,0 +1,13 @@
+diff -rauN openssh-8.4p1/sandbox-seccomp-filter.c openssh-8.4p1-sandbox-seccomp-pselect6_time64-patch/sandbox-seccomp-filter.c
+--- openssh-8.4p1/sandbox-seccomp-filter.c 2020-09-27 09:25:01.000000000 +0200
++++ openssh-8.4p1-sandbox-seccomp-pselect6_time64-patch/sandbox-seccomp-filter.c 2021-02-26 16:57:02.857964436 +0100
+@@ -267,6 +267,9 @@
+ #ifdef __NR_pselect6
+ SC_ALLOW(__NR_pselect6),
+ #endif
++#ifdef __NR_pselect6_time64
++ SC_ALLOW(__NR_pselect6_time64),
++#endif
+ #ifdef __NR_read
+ SC_ALLOW(__NR_read),
+ #endif