summaryrefslogtreecommitdiff
path: root/core/linux
diff options
context:
space:
mode:
Diffstat (limited to 'core/linux')
-rw-r--r--core/linux/PKGBUILD10
-rw-r--r--core/linux/config.i4869
-rw-r--r--core/linux/config.i6864
-rw-r--r--core/linux/config.pentium44
4 files changed, 16 insertions, 11 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 39616b7b..18a35741 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,14 +1,14 @@
-# upstream git revision: 09c5485543213dd00210e98d71632a0ff9c2c5cc
+# upstream git revision: 77a72c93c50db83247afca1246500f5b2582feb9
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '5d58a2115892839997ae7dcca226697c34b656de7685cb3eb8696451dc5100a0' ]; then
- sha256sums_pentium4=('7ed172c2046bb1c38369524ae4d0a0b5fba38e07f32efcdd9b089a431be57ae2')
- sha256sums_i686=('7ed172c2046bb1c38369524ae4d0a0b5fba38e07f32efcdd9b089a431be57ae2')
- sha256sums_i486=('ce0f2ff4dc7b2a2b6e2cdb2a0372734598a2911c2e30a0593e1355b5cf0bcd51')
+ if [ "${sha256sums[${i}]}" = 'eeb60c19586bf5855eeaeac8323b0012107bfa74f9efa0c8e129d979d38f1f31' ]; then
+ sha256sums_pentium4=('c472745d20c172341d5ca1b66dd457ff90003830da91f8a76d1223dba98a594f')
+ sha256sums_i686=('c472745d20c172341d5ca1b66dd457ff90003830da91f8a76d1223dba98a594f')
+ sha256sums_i486=('0e7ff0c025f5bd3e6faf8240876877e1b7919712b21b2db59920182eea031f84')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index deed11b5..ee7cdb12 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.4.3-arch1 Kernel Configuration
+# Linux/x86 5.4.7-arch1 Kernel Configuration
#
#
@@ -8693,7 +8693,12 @@ CONFIG_RPMSG_QCOM_GLINK_RPM=m
CONFIG_RPMSG_VIRTIO=m
# end of Rpmsg drivers
-# CONFIG_SOUNDWIRE is not set
+CONFIG_SOUNDWIRE=m
+
+#
+# SoundWire Devices
+#
+# CONFIG_SOUNDWIRE_INTEL is not set
#
# SOC (System On Chip) specific Drivers
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index 0b941546..85928e04 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.4.3-arch1 Kernel Configuration
+# Linux/x86 5.4.7-arch1 Kernel Configuration
#
#
@@ -8750,7 +8750,7 @@ CONFIG_RPMSG_QCOM_GLINK_RPM=m
CONFIG_RPMSG_VIRTIO=m
# end of Rpmsg drivers
-CONFIG_SOUNDWIRE=y
+CONFIG_SOUNDWIRE=m
#
# SoundWire Devices
diff --git a/core/linux/config.pentium4 b/core/linux/config.pentium4
index 0b941546..85928e04 100644
--- a/core/linux/config.pentium4
+++ b/core/linux/config.pentium4
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.4.3-arch1 Kernel Configuration
+# Linux/x86 5.4.7-arch1 Kernel Configuration
#
#
@@ -8750,7 +8750,7 @@ CONFIG_RPMSG_QCOM_GLINK_RPM=m
CONFIG_RPMSG_VIRTIO=m
# end of Rpmsg drivers
-CONFIG_SOUNDWIRE=y
+CONFIG_SOUNDWIRE=m
#
# SoundWire Devices