summaryrefslogtreecommitdiff
path: root/core/linux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/linux/PKGBUILD')
-rw-r--r--core/linux/PKGBUILD44
1 files changed, 33 insertions, 11 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 343c4f72..cb896d87 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,14 +1,14 @@
-# upstream git revision: c8b332b2572d4e1985e6d73740261de9d4b59618
+# upstream git revision: 139b450455d98afe00208d55dc85421fe2cfff11
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'bba324c92b62966492f27a02969910be2937668d0b39c7db2bb444e753b642af' ]; then
- sha256sums_pentium4=('0b8c7daed7716abd8d74f6159599915eada36643225fd8f20e91a54e34ed1168')
- sha256sums_i686=('7cd37cb8ae45dc4c46c8657c96d89a7a1b62ca7666b2e0d45e3240f86fa0784f')
- sha256sums_i486=('e91b2d4992e241979c9f68d87303ba4db5277d9d6a9116bfcf4c706cbe906dd1')
+ if [ "${sha256sums[${i}]}" = '5e34f17f45b3623bd8350b4d2c23ad7525b75c327cc49ec3dc37e3ee168d2f46' ]; then
+ sha256sums_pentium4=('ee2e8c1710b3d89d2a17593ad7a80842d56e5cd4fdba925c514a7e41c475f183')
+ sha256sums_i686=('1c136b7e2e8de17d75bcd41a75f7e3cde259bca2ab9e8477b79112e65dcdea51')
+ sha256sums_i486=('aa403d4c9a1b6ac3f198025b8a6e8cd8a99a6fdaf83406b9cdc505689b120e90')
fi
done
@@ -36,10 +36,12 @@ eval "$(
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
'
)
if [ -n "${infos}" ]; then
@@ -91,7 +93,27 @@ for ((i=0; i<${#source[@]}; i++)); do
fi
done
+# upstream prepare() does already do the *.patch patching
+
# avoid using zstd compression in ultra mode (exhausts virtual memory)
source+=('core/linux/no-ultra-zstd.patch')
-sha256sums+=('3997ce6033fdf950a9960f1db720b38c47b1a2e06ab75fc6712c154f596e7c47')
-# upstream prepare() does already do the *.patch patching
+sha256sums+=('d32270be5fd9c3e3ba50f3aef33f6cfcb85be0c8216f03b777287cc621fdff28')
+
+# temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
+pkgname=(
+ $(
+ printf '%s\n' "${pkgname[@]}" | \
+ grep -v '^\$pkgbase-docs'
+ )
+)
+eval "$(
+ declare -f build | \
+ sed '
+ s/\bhtmldocs\b//
+ '
+)"
+makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+makedepends=(${makedepends[@]//python-sphinx/})
+makedepends=(${makedepends[@]//graphviz/})
+makedepends=(${makedepends[@]//imagemagick/})
+makedepends=(${makedepends[@]//texlive-latexextra/})