summaryrefslogtreecommitdiff
path: root/core/glibc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/glibc/PKGBUILD')
-rw-r--r--core/glibc/PKGBUILD44
1 files changed, 43 insertions, 1 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index d8798b49..07f6e51f 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -35,7 +35,7 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f check | \
sed '
- /make check/d
+ /make -O check/d
'
)"
@@ -64,3 +64,45 @@ if [ "${CARCH}" = "pentium4" ]; then
'
)"
fi
+
+# https://lwn.net/Articles/845329/, ISA-Level breakage in glibc 2.33
+# disabling all ISA level guessing for now (see FS32#145)
+eval "$(
+ declare -f build | \
+ sed '
+ s|--prefix=/usr|--prefix=/usr libc_cv_include_x86_isa_level=no|g
+ '
+)"
+
+# upstream test skipping breaks Makefiles in test, also glibc 2.25 currently fails
+# in the following tests:
+# FAIL: elf/tst-audit-tlsdesc
+#FAIL: elf/tst-audit-tlsdesc-dlopen
+#FAIL: elf/tst-gnu2-tls1
+#FAIL: math/test-float-clog10
+#FAIL: math/test-float32-clog10
+#FAIL: misc/tst-bz21269
+#FAIL: misc/tst-ntp_gettime
+#FAIL: misc/tst-ntp_gettimex
+#FAIL: time/tst-adjtime
+#FAIL: time/tst-clock2
+# the last once are exactly the once we had to patch, so we ignore this.
+eval "$(
+ declare -f check | \
+ sed '
+ s/skip_test tst-ntp_gettimex/skip_test tst-ntp_gettimex-time64/
+ s/skip_test tst-ntp_gettime/skip_test tst-ntp_gettime-time64/
+ s/skip_test tst-adjtime/skip_test tst-adjtime-time64/
+ s/skip_test tst-clock2/skip_test tst-clock2-time64/
+ s/make -O check/make -O check || true/
+ '
+)"
+
+# readd C.UTF-8 locale generate with the removed lib32 sed above
+eval "$(
+ declare -f build | \
+ sed '
+ $ i \
+ locale/localedef -c -f ../glibc/localedata/charmaps/UTF-8 -i ../glibc/localedata/locales/C ../C.UTF-8/
+ '
+)"