summaryrefslogtreecommitdiff
path: root/core/gcc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/gcc/PKGBUILD')
-rw-r--r--core/gcc/PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/core/gcc/PKGBUILD b/core/gcc/PKGBUILD
index fecb7d16..4e1592fc 100644
--- a/core/gcc/PKGBUILD
+++ b/core/gcc/PKGBUILD
@@ -13,8 +13,9 @@ eval "$(
'
declare -f build | \
sed '
- s/--enable-multilib/--disable-multilib/
- s,--with-bugurl=https://bugs\.archlinux\.org/,--with-bugurl=https://bugs.archlinux32.org/,
+ /configure/ s/--enable-multilib/--disable-multilib/
+ /configure/ s,--with-bugurl=https://bugs\.archlinux\.org/,--with-bugurl=https://bugs.archlinux32.org/,
+ /configure/ s/;$/ --build=$CARCH-pc-linux-gnu;/
'
declare -f package_gcc-libs | \
sed '
@@ -83,7 +84,7 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- /enable-languages/ s/ada//
+ /enable-languages/ s/,ada//
'
)"
@@ -103,7 +104,7 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f package_gcc-libs | \
sed '
- s/libgfortran/libquadmath libgfortran/
+ /for lib in / s/libgfortran/libquadmath libgfortran/
'
)"