summaryrefslogtreecommitdiff
path: root/core/file/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/file/PKGBUILD')
-rw-r--r--core/file/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/core/file/PKGBUILD b/core/file/PKGBUILD
index ab132fd5..ba1e0f05 100644
--- a/core/file/PKGBUILD
+++ b/core/file/PKGBUILD
@@ -1,5 +1,12 @@
-# seccomp doesn't add rules for 64-bit filesystem function on 32-bit
-# systems (e.g. fstat64)
+# file doesn't add seccomp rules for 64-bit filesystem function on 32-bit
+# systems (e.g. fstat64), in allmost all functions of file
+# various sycalls like fork, pipe, wait4 have no ALLOW_RULE, somehow
+# works on 64-bit, not on 32-bit. (-z option)
+# Hence: disabling seccomp support completly!
-source+=('file-5.33-seccomp-32bit.patch')
-md5sums+=('5e0c3072ad745b55c8560425e6bb904c')
+eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure --disable-libseccomp/
+ '
+)"