summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/opensubdiv/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/opensubdiv/PKGBUILD b/community/opensubdiv/PKGBUILD
index 27a66260..7ee1e57b 100644
--- a/community/opensubdiv/PKGBUILD
+++ b/community/opensubdiv/PKGBUILD
@@ -1,4 +1,19 @@
+# no CUDA
makedepends=(
${makedepends[@]/cuda/}
)
pkgdesc+=", without CUDA support"
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DNO_CUDA=ON /
+ '
+)"
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cuda.*patch/d
+ '
+)"