summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-30 09:46:04 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-30 09:46:04 +0200
commit928c9e470d2fab24c981d7723684fff4d4415711 (patch)
tree1d7cc1fe9b1b6ed629adecbaeaaaa6698fddbd24 /community
parente6ec0980a301d6625aa071f456ee33d29d312b32 (diff)
downloadpackages-928c9e470d2fab24c981d7723684fff4d4415711.tar.xz
community/opensubdiv: disabling CUDA explicitely with -DNO_CUDA=ON
Diffstat (limited to 'community')
-rw-r--r--community/opensubdiv/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/opensubdiv/PKGBUILD b/community/opensubdiv/PKGBUILD
index 27a66260..7ee1e57b 100644
--- a/community/opensubdiv/PKGBUILD
+++ b/community/opensubdiv/PKGBUILD
@@ -1,4 +1,19 @@
+# no CUDA
makedepends=(
${makedepends[@]/cuda/}
)
pkgdesc+=", without CUDA support"
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DNO_CUDA=ON /
+ '
+)"
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cuda.*patch/d
+ '
+)"