summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/trojita/PKGBUILD14
-rw-r--r--community/trojita/trojita-0.7-QPainterPath.patch11
-rw-r--r--community/trojita/trojita-fix-crash.patch30
3 files changed, 55 insertions, 0 deletions
diff --git a/community/trojita/PKGBUILD b/community/trojita/PKGBUILD
new file mode 100644
index 00000000..4cf46311
--- /dev/null
+++ b/community/trojita/PKGBUILD
@@ -0,0 +1,14 @@
+# https://bugs.archlinux32.org/index.php?do=details&task_id=146
+# https://bugs.kde.org/show_bug.cgi?id=432827
+source+=('trojita-0.7-QPainterPath.patch')
+sha256sums+=('d8595d5970d11d9146d24332d2292f811fe4f2854574c996b97efdcdc8eedfb4')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*trojita-fix-crash/ a patch -p1 -i ../trojita-0.7-QPainterPath.patch
+ '
+)"
+
+# https://bugs.archlinux32.org/index.php?do=details&task_id=146
+# patch URL run away, fetched cf2364b80fa8ae844df8350cd5833d47cce235f2 from git
+sha256sums[3]="96d5400ede5b015532d2c11b192c40f583c3b534d6d2df011d0600307e2915ea"
diff --git a/community/trojita/trojita-0.7-QPainterPath.patch b/community/trojita/trojita-0.7-QPainterPath.patch
new file mode 100644
index 00000000..f588c2f2
--- /dev/null
+++ b/community/trojita/trojita-0.7-QPainterPath.patch
@@ -0,0 +1,11 @@
+diff -rauN trojita-0.7/src/Gui/Window.cpp trojita-0.7-QPainterPath-patch/src/Gui/Window.cpp
+--- trojita-0.7/src/Gui/Window.cpp 2016-06-15 09:17:23.000000000 +0200
++++ trojita-0.7-QPainterPath-patch/src/Gui/Window.cpp 2021-02-12 07:56:19.202926373 +0100
+@@ -45,6 +45,7 @@
+ #include <QToolTip>
+ #include <QUrl>
+ #include <QWheelEvent>
++#include <QPainterPath>
+
+ #include "configure.cmake.h"
+ #include "Common/Application.h"
diff --git a/community/trojita/trojita-fix-crash.patch b/community/trojita/trojita-fix-crash.patch
new file mode 100644
index 00000000..9a302728
--- /dev/null
+++ b/community/trojita/trojita-fix-crash.patch
@@ -0,0 +1,30 @@
+diff --git a/src/Imap/Network/FileDownloadManager.cpp b/src/Imap/Network/FileDownloadManager.cpp
+index 16b6c8dfc93727bd1696abaab8336b06794b3a02..c3f72176abdfd0981a5ac37ec69060fb3c7aa797 100644
+--- a/src/Imap/Network/FileDownloadManager.cpp
++++ b/src/Imap/Network/FileDownloadManager.cpp
+@@ -139,7 +139,9 @@ void FileDownloadManager::downloadMessage()
+
+ void FileDownloadManager::onPartDataTransfered()
+ {
+- Q_ASSERT(reply);
++ if (!reply) {
++ return;
++ }
+ if (reply->error() == QNetworkReply::NoError) {
+ if (!saving.open(QIODevice::WriteOnly)) {
+ emit transferError(saving.errorString());
+@@ -192,11 +194,11 @@ void FileDownloadManager::onCombinerTransferError(const QString &message)
+
+ void FileDownloadManager::deleteReply(QNetworkReply *reply)
+ {
+- if (reply == this->reply) {
++ if (reply && reply == this->reply) {
+ if (!saved)
+ onPartDataTransfered();
+- delete reply;
+- this->reply = 0;
++ reply->deleteLater();
++ this->reply = nullptr;
+ }
+ }
+