summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libfm/PKGBUILD35
1 files changed, 32 insertions, 3 deletions
diff --git a/community/libfm/PKGBUILD b/community/libfm/PKGBUILD
index bb01b525..3ee20db8 100644
--- a/community/libfm/PKGBUILD
+++ b/community/libfm/PKGBUILD
@@ -1,4 +1,33 @@
# breaking the cycle with menu-cache on i486
-makedepends=(${makedepends[@]//menu-cache/})
-makedepends_i686+=(menu-cache)
-makedepends_pentium4=("${makedepends_i686[@]}")
+depends=(${depends[@]//menu-cache/})
+depends_i686+=(menu-cache)
+depends_pentium4=("${depends_i686[@]}")
+
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|./configure --with-extra-only |
+ /mv.*\/usr\/bin/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_libfm | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk2 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk3 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+fi