summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-07 17:36:47 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-07 17:36:47 +0100
commit1105b29fcab8dec43c49abc0bd6b46609f364230 (patch)
treefc32a38d9d15fab0bee905e2d64debcf3465b5a2 /community
parentc1b1b106563c9dd66c84f55a25b57660255c44c9 (diff)
downloadpackages-1105b29fcab8dec43c49abc0bd6b46609f364230.tar.xz
community/libfm: more cycle breaking
Diffstat (limited to 'community')
-rw-r--r--community/libfm/PKGBUILD35
1 files changed, 32 insertions, 3 deletions
diff --git a/community/libfm/PKGBUILD b/community/libfm/PKGBUILD
index bb01b525..3ee20db8 100644
--- a/community/libfm/PKGBUILD
+++ b/community/libfm/PKGBUILD
@@ -1,4 +1,33 @@
# breaking the cycle with menu-cache on i486
-makedepends=(${makedepends[@]//menu-cache/})
-makedepends_i686+=(menu-cache)
-makedepends_pentium4=("${makedepends_i686[@]}")
+depends=(${depends[@]//menu-cache/})
+depends_i686+=(menu-cache)
+depends_pentium4=("${depends_i686[@]}")
+
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|./configure --with-extra-only |
+ /mv.*\/usr\/bin/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_libfm | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk2 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk3 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+fi