summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/blender/PKGBUILD13
-rw-r--r--community/blender/blender-idprop_create-static-assert-float.patch12
-rw-r--r--community/blender/no-sse2.patch23
-rw-r--r--community/botan/PKGBUILD6
-rw-r--r--community/calibre/PKGBUILD7
-rw-r--r--community/carla/PKGBUILD8
-rw-r--r--community/ckermit/PKGBUILD9
-rw-r--r--community/ckermit/ckucmd-IO_file_flags.patch11
-rw-r--r--community/coin-or-cbc/PKGBUILD2
-rw-r--r--community/crun/PKGBUILD2
-rw-r--r--community/exa/PKGBUILD13
-rw-r--r--community/fasm/PKGBUILD13
-rw-r--r--community/gcc10/PKGBUILD94
-rw-r--r--community/ghc/PKGBUILD11
-rw-r--r--community/giada/PKGBUILD7
-rw-r--r--community/ispc/PKGBUILD41
-rw-r--r--community/ispc/ispc-1.16.1-host-amd64.patch16
-rw-r--r--community/librsvg-og/PKGBUILD41
-rw-r--r--community/netplan/PKGBUILD13
-rw-r--r--community/netplan/netplan-0.102-no-pandoc.patch22
-rw-r--r--community/nodejs-lts-fermium/PKGBUILD (renamed from community/nodejs-lts-erbium/PKGBUILD)2
-rw-r--r--community/nvidia-cg-toolkit/PKGBUILD15
-rw-r--r--community/perl-cgi/PKGBUILD9
-rw-r--r--community/python-apipkg/PKGBUILD7
-rw-r--r--community/python-babel/PKGBUILD10
-rw-r--r--community/python-build/PKGBUILD17
-rw-r--r--community/python-debugpy/PKGBUILD11
-rw-r--r--community/python-hglib/PKGBUILD11
-rw-r--r--community/python-installer/PKGBUILD14
-rw-r--r--community/python-jedi/PKGBUILD15
-rw-r--r--community/python-pluggy/PKGBUILD5
-rw-r--r--community/python-pysocks/PKGBUILD3
-rw-r--r--community/python-pytest-cov/PKGBUILD3
-rw-r--r--community/python-pytest/PKGBUILD9
-rw-r--r--community/python-pyudev/PKGBUILD15
-rw-r--r--community/python-pyzmq/PKGBUILD3
-rw-r--r--community/python-recommonmark/PKGBUILD19
-rw-r--r--community/python-simplejson/PKGBUILD4
-rw-r--r--community/python-sphinxcontrib-applehelp/PKGBUILD (renamed from community/python-jinja/PKGBUILD)0
-rw-r--r--community/python-sphinxcontrib-devhelp/PKGBUILD (renamed from community/python-sphinx/PKGBUILD)0
-rw-r--r--community/python-sphinxcontrib-htmlhelp/PKGBUILD (renamed from community/python-more-itertools/PKGBUILD)3
-rw-r--r--community/python-sphinxcontrib-jsmath/PKGBUILD (renamed from community/python-sphinxcontrib-qthelp/PKGBUILD)0
-rw-r--r--community/python-wheel/PKGBUILD2
-rw-r--r--community/python-xarray/PKGBUILD2
-rw-r--r--community/reflector/PKGBUILD7
-rw-r--r--community/s2n-tls/PKGBUILD10
-rw-r--r--community/spiped/PKGBUILD2
-rw-r--r--community/tinyemu/PKGBUILD11
-rw-r--r--community/ttf-ibm-plex/PKGBUILD2
-rw-r--r--community/xrootd4/PKGBUILD2
50 files changed, 329 insertions, 248 deletions
diff --git a/community/blender/PKGBUILD b/community/blender/PKGBUILD
index 47de888e..03a1eeb7 100644
--- a/community/blender/PKGBUILD
+++ b/community/blender/PKGBUILD
@@ -12,7 +12,7 @@ eval "$(
'
)"
source_i686+=('no-sse2.patch')
-sha512sums_i686+=('c811828bf178a69315498f1f7a04da26c7be11c05b2f8b505148aac4ee2bb4f29b683144cf6b99fab140ef3bdb6687350396cdea08de7fc5e61a22222e9be6e9')
+sha512sums_i686+=('87da2bedb90af6dee559ef9d1eb83262ba75fb412aba83dcb2b88fe9c0740ff75ad336331033fec7a14ad6ecc3dd70f8f4742f147594e8dc530197dd51922c01')
if [ "${CARCH}" = 'i686' ]; then
eval "$(
declare -f prepare \
@@ -41,3 +41,14 @@ depends=(
depends=(
${depends[@]/openvdb/}
)
+
+# float_t is a long double on 32-bit, but it's a primitive in all cases anyway
+# (seems to be in a part of the blendkernel on i686 only..)
+source+=('blender-idprop_create-static-assert-float.patch')
+sha512sums+=('36b98ec7e53402909a9e531c30b444b1afc22cc597c5bb3393c73862929dcc6275b00a53de6171a81af3c8804d233359d2e797886d0b776e7a9b29b23ce24e3b')
+eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -Np1 -i "$srcdir"/blender-idprop_create-static-assert-float.patch
+ '
+)"
diff --git a/community/blender/blender-idprop_create-static-assert-float.patch b/community/blender/blender-idprop_create-static-assert-float.patch
new file mode 100644
index 00000000..5be594e5
--- /dev/null
+++ b/community/blender/blender-idprop_create-static-assert-float.patch
@@ -0,0 +1,12 @@
+diff -rauN blender/source/blender/blenkernel/intern/idprop_create.cc blender-idprop_create-static-assert-float-patch/source/blender/blenkernel/intern/idprop_create.cc
+--- blender/source/blender/blenkernel/intern/idprop_create.cc 2022-04-03 14:32:20.257350527 +0200
++++ blender-idprop_create-static-assert-float-patch/source/blender/blenkernel/intern/idprop_create.cc 2022-04-03 14:35:17.851234918 +0200
+@@ -92,7 +92,7 @@
+ Span<PrimitiveType> values)
+ {
+ static_assert(std::is_same_v<PrimitiveType, int32_t> || std::is_same_v<PrimitiveType, float_t> ||
+- std::is_same_v<PrimitiveType, double>,
++ std::is_same_v<PrimitiveType, float> || std::is_same_v<PrimitiveType, double>,
+ "Allowed values for PrimitiveType are int32_t, float and double.");
+ static_assert(!std::is_same_v<PrimitiveType, int32_t> || id_property_subtype == IDP_INT,
+ "PrimitiveType and id_property_type do not match (int32_t).");
diff --git a/community/blender/no-sse2.patch b/community/blender/no-sse2.patch
index 88620e02..a32f7c64 100644
--- a/community/blender/no-sse2.patch
+++ b/community/blender/no-sse2.patch
@@ -1,13 +1,12 @@
-diff -rauN blender-vanilla/intern/cycles/bvh/bvh_embree.cpp blender-no-sse2-patch/intern/cycles/bvh/bvh_embree.cpp
---- blender-vanilla/intern/cycles/bvh/bvh_embree.cpp 2021-07-05 17:31:59.689914965 +0200
-+++ blender-no-sse2-patch/intern/cycles/bvh/bvh_embree.cpp 2021-07-05 17:33:10.596795518 +0200
-@@ -304,7 +304,9 @@
- rtc_device(NULL),
- build_quality(RTC_BUILD_QUALITY_REFIT)
- {
-+#if defined(__x86_64__) || defined(_M_X64)
- SIMD_SET_FLUSH_TO_ZERO;
-+#endif
- }
+diff -rauN blender-vanilla/CMakeLists.txt blender-no-sse2-patch/CMakeLists.txt
+--- blender-vanilla/CMakeLists.txt 2022-04-07 16:36:48.842414275 +0200
++++ blender-no-sse2-patch/CMakeLists.txt 2022-04-07 16:37:12.012470531 +0200
+@@ -981,7 +981,7 @@
+ # Test SIMD support, before platform includes to determine if sse2neon is needed.
+ if(WITH_CPU_SIMD)
+ set(COMPILER_SSE_FLAG)
+- set(COMPILER_SSE2_FLAG)
++# set(COMPILER_SSE2_FLAG)
- BVHEmbree::~BVHEmbree()
+ # Test Neon first since macOS Arm can compile and run x86-64 SSE binaries.
+ TEST_NEON_SUPPORT()
diff --git a/community/botan/PKGBUILD b/community/botan/PKGBUILD
deleted file mode 100644
index 937eee9b..00000000
--- a/community/botan/PKGBUILD
+++ /dev/null
@@ -1,6 +0,0 @@
-eval "$(
- declare -f build | \
- sed '
- s,/configure\.py ,\0--cpu=i686 ,
- '
-)"
diff --git a/community/calibre/PKGBUILD b/community/calibre/PKGBUILD
index add1c241..43e09de8 100644
--- a/community/calibre/PKGBUILD
+++ b/community/calibre/PKGBUILD
@@ -5,3 +5,10 @@ eval "$(
s/.*setup.py test/CI=true &/g
'
)"
+
+# ignore checksum
+sha256sums[0]='SKIP'
+
+# disabled testing, too many Python stuff currently broken
+unset check
+unset checkdepends
diff --git a/community/carla/PKGBUILD b/community/carla/PKGBUILD
index 48189396..aa111698 100644
--- a/community/carla/PKGBUILD
+++ b/community/carla/PKGBUILD
@@ -5,9 +5,9 @@ if [ "${CARCH}" = "i686" ]; then
sha512sums+=('b481a9f9b1e404536a42706a36255216f64e49022c1c0f012e40be2941eb4a74b8d2b2f30998e16678a3d46e57dbeffa6f63259afff5a94a1bc4c7d8ba35a67c')
b2sums+=('cb314334ffb6552f11a6d5b3a2de707a846d316956a565ab350afee450c224ab693beace1a0e52b50d9150beca592d5ec79b3e8014bca2c4c8e44450dfbe6ee3')
eval "$(
- declare -f build | \
+ declare -f prepare | \
sed '
- /make features/ i \
+ /git.*cherry.*/ i \
patch -Np1 -i "$srcdir/carla-git-no-sse2.patch"
'
)"
@@ -18,9 +18,9 @@ if [ "${CARCH}" = "i486" ]; then
sha512sums+=('bdce143bf9001c970d4001f9a65842f5f7130a26cb6c2804062146f80f672132181af0630d379fae5c51690761983df4cf1b37413d094d0157699dd509f828e4')
b2sums+=('294e7b6a3a902992b860867088e21e96f66316e41db8ecd510bf3ef6912ba0432ceb0abfe2ca6f78072858ed6e805e4f24f7aca598688eac45f7b41b8d5e72cd')
eval "$(
- declare -f build | \
+ declare -f prepare | \
sed '
- /make features/ i \
+ /git.*cherry.*/ i \
patch -Np1 -i "$srcdir/carla-git-no-sse.patch"
'
)"
diff --git a/community/ckermit/PKGBUILD b/community/ckermit/PKGBUILD
deleted file mode 100644
index 5f4acf8d..00000000
--- a/community/ckermit/PKGBUILD
+++ /dev/null
@@ -1,9 +0,0 @@
-source+=('ckucmd-IO_file_flags.patch')
-sha512sums+=('0a49ac384b7a49efe20cf4842a0f1ebe3f504aa259f9a9c956ad5b85fd49964a44191a99b8111a7868a9e9be37d6093f3db3bbe907d20605e2664b64395e5f17')
-eval "$(
- declare -f prepare | \
- sed '
- /patch/ a patch -p1 < ckucmd-IO_file_flags.patch
- '
-)"
-
diff --git a/community/ckermit/ckucmd-IO_file_flags.patch b/community/ckermit/ckucmd-IO_file_flags.patch
deleted file mode 100644
index 87886f17..00000000
--- a/community/ckermit/ckucmd-IO_file_flags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -rauN cku302/ckucmd.c cku302-ckucmd-IO_file_flags-patch/ckucmd.c
---- cku302/ckucmd.c 2011-07-14 14:14:37.000000000 +0200
-+++ cku302-ckucmd-IO_file_flags-patch/ckucmd.c 2019-06-17 14:19:01.124728510 +0200
-@@ -7370,6 +7370,7 @@
-
- /* Here we must look inside the stdin buffer - highly platform dependent */
-
-+#define _IO_file_flags
- #ifdef _IO_file_flags /* Linux */
- x = (int) ((stdin->_IO_read_end) - (stdin->_IO_read_ptr));
- debug(F101,"cmdconchk _IO_file_flags","",x);
diff --git a/community/coin-or-cbc/PKGBUILD b/community/coin-or-cbc/PKGBUILD
new file mode 100644
index 00000000..65382946
--- /dev/null
+++ b/community/coin-or-cbc/PKGBUILD
@@ -0,0 +1,2 @@
+# hangs slaves
+unset check
diff --git a/community/crun/PKGBUILD b/community/crun/PKGBUILD
new file mode 100644
index 00000000..73298fe2
--- /dev/null
+++ b/community/crun/PKGBUILD
@@ -0,0 +1,2 @@
+# criu is blacklisted
+depends=(${depends[@]//criu/})
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index 81065c10..914a7177 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -1,6 +1,3 @@
-# rust currenly broken, is based on LLVM 11
-makedepends+=(llvm11)
-
# pandoc is mainly broken currently (FS32#180)
makedepends=(${makedepends[@]//pandoc/})
eval "$(
@@ -16,3 +13,13 @@ eval "$(
/exa_colors.5/d
'
)"
+
+# CARCH pentium4 makes compilation fail
+if [ "$CARCH" = 'pentium4' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/--target "$CARCH-unknown-linux-gnu"/--target "i686-unknown-linux-gnu"/
+ '
+ )"
+fi
diff --git a/community/fasm/PKGBUILD b/community/fasm/PKGBUILD
new file mode 100644
index 00000000..15201927
--- /dev/null
+++ b/community/fasm/PKGBUILD
@@ -0,0 +1,13 @@
+depends_i486+=('glibc')
+depends_i686+=('glibc')
+depends_pentium4+=('glibc')
+
+eval "$(
+ declare -f build | \
+ sed '
+ /if .*CARCH.* == .*x86_64.*/,/fi/{s/.*//g}
+ /mv/ i \
+ SRCDIR=Linux \
+ ./fasm source/${SRCDIR}/fasm.asm
+ '
+)"
diff --git a/community/gcc10/PKGBUILD b/community/gcc10/PKGBUILD
deleted file mode 100644
index 1556c78d..00000000
--- a/community/gcc10/PKGBUILD
+++ /dev/null
@@ -1,94 +0,0 @@
-# remove tsan (thread sanitizer) plugin, not available for i686
-pkgname=(
- $(
- printf '%s\n' "${pkgname[@]}" | \
- grep -vFx 'lib32-gcc-libs'
- )
-)
-unset -f 'package_lib32-gcc-libs'
-eval "$(
- declare -f prepare | \
- sed '
- \,/s/lib64/lib/, d
- '
- declare -f build | \
- sed '
- /configure/ s/--enable-multilib/--disable-multilib/
- /configure/ s,--with-bugurl=https://bugs\.archlinux\.org/,--with-bugurl=https://bugs.archlinux32.org/,
- /configure/ s/;$/ --build=$CHOST;/
- '
- declare -f package_gcc10-libs | \
- sed '
- s/\$pkgname-multilib//
- s@libsanitizer/{a,l,ub,t}san@libsanitizer/{a,l,ub}san@
- /provides=/s/libtsan.so//
- \@/usr/lib32/@ d
- '
- declare -f package_gcc10 | \
- sed '
- s/"lib32-gcc-libs[^"]*"//g
- s@make.*tsan.*install.*@#\0@
- '
-)"
-eval "$(
- for name in "${pkgname[@]}"; do
- declare -f package_${name} | \
- sed '
- s/$pkgname-multilib//
- s/{,32}//
- \,/lib32/,d
- \,/32/,d
- '
- done
-)"
-
-# i486-specific
-
-if [ "${CARCH}" = "i486" ]; then
- # building toolchain (gcc): again, lobtool problems
- # /usr/lib/gcc/i486-pc-linux-gnu/7.3.0/ld: cannot find -lquadmath
- # collect2: error: ld returned 1 exit status
- # libtool: install: error: relink `libgfortran.la' with the above command before installing it
- # make: Leaving directory '/build/gcc/src/gcc-build/i486-pc-linux-gnu/libgfortran'
- # => wrong link order: libgfortran requires libquadmath
- eval "$(
- declare -f package_gcc10-libs | \
- sed '
- /for lib in / s/libgfortran/libquadmath libgfortran/
- '
- )"
-
- # disable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet=auto/--disable-cet/
- '
- )"
-
-else
-
- # force enable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet=auto/--enable-cet/
- '
- )"
-
-fi
-
-makedepends_pentium4=("${makedepends_i686[@]}")
-
-# avoid CHOST double gcc-libs
-eval "$(
- declare -f package_gcc10 | \
- sed '
- /rm.*_libdir.*/ a \
- rm -f "$pkgdir"/usr/lib/gcc/*-pc-linux-gnu/${pkgver}/libgcc_s.so*;
- '
-)"
-
-source[1]='isl-0.24.tar.xz::https://downloads.sourceforge.net/project/libisl/isl-0.24.tar.xz?ts=gAAAAABhojIcYmUfplFkh4GCklCNjXe6c5A561-eOrQD92l7Dd9Lw5vOoApEOzfk2XL8NElrqvTKrH0enBWHiWCznbwG1pkAaQ%3D%3D&r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Flibisl%2Ffiles%2Fisl-0.24.tar.xz%2Fdownload%3Fuse_mirror%3Ddeac-fra%26download%3D%26failedmirror%3Ddeac-riga.dl.sourceforge.net'
-
-unset check
diff --git a/community/ghc/PKGBUILD b/community/ghc/PKGBUILD
new file mode 100644
index 00000000..e1aa6b7f
--- /dev/null
+++ b/community/ghc/PKGBUILD
@@ -0,0 +1,11 @@
+# bootstrapping from binary version (when ghc-static is broken)
+makedepends=(${makedepends[@]//ghc-static/})
+makedepends_i486+=(ghc90-bin libffi33)
+makedepends_i686+=("${makedepends_i486[@]}")
+makedepends_pentium4=("${makedepends_i686[@]}")
+eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|GHC=/usr/bin/ghc-9.0 ./configure|
+ '
+)"
diff --git a/community/giada/PKGBUILD b/community/giada/PKGBUILD
deleted file mode 100644
index 40764d66..00000000
--- a/community/giada/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-# atomics for 486
-eval "$(
- declare -f build | \
- sed '
- 3 i LDFLAGS="-latomic"
- '
-)"
diff --git a/community/ispc/PKGBUILD b/community/ispc/PKGBUILD
new file mode 100644
index 00000000..ead7793e
--- /dev/null
+++ b/community/ispc/PKGBUILD
@@ -0,0 +1,41 @@
+# disable GENX
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DGENX_ENABLED=ON/-DGENX_ENABLED=OFF/
+ '
+)"
+
+# don't assume to be on a 64-bit Intel host and draw in gnu64 headers everywhere
+source+=('ispc-1.16.1-host-amd64.patch')
+sha256sums+=('7a4a631ad178b13f9ab68e6aec94469e30a4b9dec48d40f732a701b4ed4d5c1f')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname-$pkgver" \
+ patch -Np1 -i "$srcdir/ispc-1.16.1-host-amd64.patch"
+ '
+)"
+
+# ignore test results, GENX tests failing obviously
+eval "$(
+ declare -f build | \
+ sed '
+ s/\(make.*check-all\)/\1 || true/
+ '
+)"
+
+# packaging issue now as we are not building everything
+eval "$(
+ declare -f package | \
+ sed '
+ /rm.*build/d
+ /rm.*libispcrt_static.a/d
+ '
+)"
+
+# tests don't build when disabling GENX
+unset check
diff --git a/community/ispc/ispc-1.16.1-host-amd64.patch b/community/ispc/ispc-1.16.1-host-amd64.patch
new file mode 100644
index 00000000..78ef5f20
--- /dev/null
+++ b/community/ispc/ispc-1.16.1-host-amd64.patch
@@ -0,0 +1,16 @@
+diff -rauN ispc-1.16.1/CMakeLists.txt ispc-1.16.1-host-amd64-patch/CMakeLists.txt
+--- ispc-1.16.1/CMakeLists.txt 2021-07-16 01:04:31.000000000 +0200
++++ ispc-1.16.1-host-amd64-patch/CMakeLists.txt 2022-04-07 08:57:32.100539305 +0200
+@@ -45,9 +45,9 @@
+ project(${PROJECT_NAME})
+
+ set(X86_HOST FALSE)
+-if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
+- set(X86_HOST TRUE)
+-endif()
++#if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
++# set(X86_HOST TRUE)
++#endif()
+
+ option(X86_ENABLED "Enable x86 support" ${X86_HOST})
+ option(ARM_ENABLED "Enable ARM support" ON)
diff --git a/community/librsvg-og/PKGBUILD b/community/librsvg-og/PKGBUILD
deleted file mode 100644
index c08854e4..00000000
--- a/community/librsvg-og/PKGBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
-
-pkgname=librsvg-og
-pkgver=2.40.20
-pkgrel=1
-epoch=1
-pkgdesc="SVG rendering library old gen"
-url="https://github.com/oaken-source/librsvg-og"
-arch=(i486 i686 pentium4)
-license=(LGPL)
-depends=(gdk-pixbuf2 pango)
-conflicts_i486=(libsrvg)
-makedepends=(gobject-introspection gtk-doc git)
-provides_i486=(librsvg=${pkgver} librsvg-${pkgver%%.*}.so)
-source=("https://github.com/oaken-source/librsvg-og/archive/2.40.20.tar.gz")
-sha256sums=('5bcbd8aa34a81478f990dc62a308ee2a42ff89a4e2bc905c09fd68f525bf5643')
-
-prepare() {
- cd ${pkgname}-${pkgver}
- NOCONFIGURE=1 ./autogen.sh
-}
-
-build() {
- cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr --disable-static --disable-vala \
- --enable-gtk-doc
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
- make
-}
-
-check() {
- cd ${pkgname}-${pkgver}
- # Test suite is very dependent on the versions of
- # Cairo, Pango, FreeType and HarfBuzz
- make check || :
-}
-
-package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="$pkgdir" install
-}
diff --git a/community/netplan/PKGBUILD b/community/netplan/PKGBUILD
new file mode 100644
index 00000000..3bd27377
--- /dev/null
+++ b/community/netplan/PKGBUILD
@@ -0,0 +1,13 @@
+# currently Haskell is broken
+makedepends=(${makedepends[@]//pandoc/})
+source+=('netplan-0.102-no-pandoc.patch')
+sha256sums+=('0ab919601e4a30585f0e3e3dc224fd598d2183e2df9250c1e6e4bc894d0ace95')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd "${pkgname}-${pkgver}"\n}\n'
+ } \
+ | sed '
+ $i patch -Np1 -i "$srcdir/netplan-0.102-no-pandoc.patch"
+ '
+)"
diff --git a/community/netplan/netplan-0.102-no-pandoc.patch b/community/netplan/netplan-0.102-no-pandoc.patch
new file mode 100644
index 00000000..a1ed598d
--- /dev/null
+++ b/community/netplan/netplan-0.102-no-pandoc.patch
@@ -0,0 +1,22 @@
+diff -rauN netplan-0.102/Makefile netplan-0.102-no-pandoc-patch/Makefile
+--- netplan-0.102/Makefile 2022-02-03 12:21:36.988275585 +0100
++++ netplan-0.102-no-pandoc-patch/Makefile 2022-02-03 12:23:01.654960528 +0100
+@@ -133,12 +133,15 @@
+
+
+ %.html: %.md
+- pandoc -s --toc -o $@ $<
++# pandoc -s --toc -o $@ $<
++ echo "no pandoc" > $@
+
+ doc/netplan.5: doc/manpage-header.md doc/netplan.md doc/manpage-footer.md
+- pandoc -s -o $@ $^
++# pandoc -s -o $@ $^
++ echo "no pandoc" > $@
+
+ %.8: %.md
+- pandoc -s -o $@ $^
++# pandoc -s -o $@ $^
++ echo "no pandoc" > $@
+
+ .PHONY: clean
diff --git a/community/nodejs-lts-erbium/PKGBUILD b/community/nodejs-lts-fermium/PKGBUILD
index b9dec1da..aa8da4c8 100644
--- a/community/nodejs-lts-erbium/PKGBUILD
+++ b/community/nodejs-lts-fermium/PKGBUILD
@@ -1,3 +1,3 @@
-# EADDRINUSE
+# some random timeout
unset check
unset checkdepends
diff --git a/community/nvidia-cg-toolkit/PKGBUILD b/community/nvidia-cg-toolkit/PKGBUILD
deleted file mode 100644
index edbe23f6..00000000
--- a/community/nvidia-cg-toolkit/PKGBUILD
+++ /dev/null
@@ -1,15 +0,0 @@
-source_i686=(
- $(
- printf '%s\n' "${source_x86_64[@]}" | \
- sed '
- s/_x86_64\.tgz$/_x86.tgz/
- t
- d
- '
- )
-)
-md5sums_i686=(
- '9a9fc5108154808f3b10eafa54df1c74'
-)
-source_pentium4=("${source_i686[@]}")
-md5sums_pentium4=("${md5sums_i686[@]}")
diff --git a/community/perl-cgi/PKGBUILD b/community/perl-cgi/PKGBUILD
new file mode 100644
index 00000000..c8d3b267
--- /dev/null
+++ b/community/perl-cgi/PKGBUILD
@@ -0,0 +1,9 @@
+# temporary workaround for not having the locale set in build chroots
+# (is fixed upstream in devtools, but must update all build slaves first,
+# otherwise the whole Perl rebuild fails!)
+eval "$(
+ declare -f check | \
+ sed '
+ s/make test/LC_ALL=C LANGUAGE=C make test/
+ '
+)"
diff --git a/community/python-apipkg/PKGBUILD b/community/python-apipkg/PKGBUILD
new file mode 100644
index 00000000..3167ec8f
--- /dev/null
+++ b/community/python-apipkg/PKGBUILD
@@ -0,0 +1,7 @@
+#usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
+# or: setup.py --help [cmd1 cmd2 ...]
+# or: setup.py --help-commands
+# or: setup.py cmd --help
+#error: invalid command 'pytest'
+unset check
+unset checkdepends
diff --git a/community/python-babel/PKGBUILD b/community/python-babel/PKGBUILD
new file mode 100644
index 00000000..51c7956d
--- /dev/null
+++ b/community/python-babel/PKGBUILD
@@ -0,0 +1,10 @@
+#/build/python-babel/src/babel-2.9.1/setup.py:5: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
+# from distutils.cmd import Command
+#usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
+# or: setup.py --help [cmd1 cmd2 ...]
+# or: setup.py --help-commands
+# or: setup.py cmd --help
+#
+#error: invalid command 'pytest'
+unset check
+unset checkdepends
diff --git a/community/python-build/PKGBUILD b/community/python-build/PKGBUILD
new file mode 100644
index 00000000..7b473826
--- /dev/null
+++ b/community/python-build/PKGBUILD
@@ -0,0 +1,17 @@
+# disable documentation (needs sphinx, sphinx-furo)
+# python-sphinx-furo needs npm, which is broken on archlinux32
+# most likely since years..
+makedepends=(${makedepends[@]//python-sphinx-furo/})
+makedepends=(${makedepends[@]//python-sphinx-argparse-cli/})
+makedepends=(${makedepends[@]//python-sphinx-autodoc-typehints/})
+makedepends=(${makedepends[@]//python-sphinx/})
+eval "$(
+ declare -f build | \
+ sed '
+ /.*sphinx-build.*/d
+ '
+ declare -f package | \
+ sed '
+ /.*\/share\/doc.*/d
+ '
+)"
diff --git a/community/python-debugpy/PKGBUILD b/community/python-debugpy/PKGBUILD
new file mode 100644
index 00000000..f3266163
--- /dev/null
+++ b/community/python-debugpy/PKGBUILD
@@ -0,0 +1,11 @@
+# patch 64-bit mode compilation to 32-bit mode (and naming of
+# resulting library)
+# why we would not just ommit the mode and omit the naming in
+# the library is beyond me..
+eval "$(
+ declare -f build | \
+ sed '
+ s/-m64/-m32/g
+ s/attach_linux_amd64.so/attach_linux_i686.so/
+ '
+)"
diff --git a/community/python-hglib/PKGBUILD b/community/python-hglib/PKGBUILD
new file mode 100644
index 00000000..2064f1d3
--- /dev/null
+++ b/community/python-hglib/PKGBUILD
@@ -0,0 +1,11 @@
+#Traceback (most recent call last):
+# File "/build/python-hglib/src/python-hglib-2.6.2/test.py", line 3, in <module>
+# import nose
+# File "/usr/lib/python3.10/site-packages/nose/__init__.py", line 1, in <module>
+# from nose.core import collector, main, run, run_exit, runmodule
+# File "/usr/lib/python3.10/site-packages/nose/core.py", line 153
+# print "%s version %s" % (os.path.basename(sys.argv[0]), __version__)
+# ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+#SyntaxError: Missing parentheses in call to 'print'. Did you mean print(...)?
+unset check
+unset checkdepends
diff --git a/community/python-installer/PKGBUILD b/community/python-installer/PKGBUILD
new file mode 100644
index 00000000..9bc50ae4
--- /dev/null
+++ b/community/python-installer/PKGBUILD
@@ -0,0 +1,14 @@
+# breaking the cycle with python-spinx
+makedepends=(${makedepends[@]/python-sphinx-furo})
+makedepends=(${makedepends[@]/python-sphinx-argparse})
+makedepends=(${makedepends[@]/python-sphinx})
+eval "$(
+ declare -f build | \
+ sed '
+ /sphinx-build/d
+ '
+ declare -f package | \
+ sed '
+ /docs\/build\/html/d
+ '
+)"
diff --git a/community/python-jedi/PKGBUILD b/community/python-jedi/PKGBUILD
new file mode 100644
index 00000000..ff062da3
--- /dev/null
+++ b/community/python-jedi/PKGBUILD
@@ -0,0 +1,15 @@
+# no python-sphinx_rtd_theme, needs nodejs which is currently broken
+makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+makedepends=(${makedepends[@]//python-sphinx/})
+eval "$(
+ declare -f build | \
+ sed '
+ /sphinx-build/d
+ '
+)"
+eval "$(
+ declare -f package | \
+ sed '
+ /install.*docs\/_build.*/d
+ '
+)"
diff --git a/community/python-pluggy/PKGBUILD b/community/python-pluggy/PKGBUILD
index fcc37cc1..5906d9c8 100644
--- a/community/python-pluggy/PKGBUILD
+++ b/community/python-pluggy/PKGBUILD
@@ -1,2 +1,7 @@
+#==> Starting check()...
+#usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
+# or: setup.py --help [cmd1 cmd2 ...]
+# or: setup.py --help-commands
+# or: setup.py cmd --help
unset checkdepends
unset check
diff --git a/community/python-pysocks/PKGBUILD b/community/python-pysocks/PKGBUILD
deleted file mode 100644
index 20354d08..00000000
--- a/community/python-pysocks/PKGBUILD
+++ /dev/null
@@ -1,3 +0,0 @@
-# check() is disabled
-
-unset checkdepends
diff --git a/community/python-pytest-cov/PKGBUILD b/community/python-pytest-cov/PKGBUILD
deleted file mode 100644
index 78fbff9f..00000000
--- a/community/python-pytest-cov/PKGBUILD
+++ /dev/null
@@ -1,3 +0,0 @@
-# testsuite hangs; testsuite failures would be ignored anyways
-unset check
-unset checkdepends
diff --git a/community/python-pytest/PKGBUILD b/community/python-pytest/PKGBUILD
index 6403c888..85fbc035 100644
--- a/community/python-pytest/PKGBUILD
+++ b/community/python-pytest/PKGBUILD
@@ -1,2 +1,7 @@
-unset check
-unset checkdepends
+# some tests fail also upstream (nose)
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(test-env\/bin\/python -m pytest\)/\1 || true/
+ '
+)"
diff --git a/community/python-pyudev/PKGBUILD b/community/python-pyudev/PKGBUILD
new file mode 100644
index 00000000..022fe3c4
--- /dev/null
+++ b/community/python-pyudev/PKGBUILD
@@ -0,0 +1,15 @@
+# disable documentation (needs sphinx), building it currently leaves
+# the documentation in the package and the module broken (seen in
+# libwacom)
+makedepends=(${makedepends[@]//python-sphinx/})
+eval "$(
+ declare -f build | \
+ sed '
+ /.*sphinx.*/d
+ '
+ declare -f package | \
+ sed '
+ /.*doc\/html.*/d
+ /.*\/usr\/share\/doc.*/d
+ '
+)"
diff --git a/community/python-pyzmq/PKGBUILD b/community/python-pyzmq/PKGBUILD
deleted file mode 100644
index 5dc0b4f4..00000000
--- a/community/python-pyzmq/PKGBUILD
+++ /dev/null
@@ -1,3 +0,0 @@
-# check() raises OOM-errors
-unset check
-unset checkdepends
diff --git a/community/python-recommonmark/PKGBUILD b/community/python-recommonmark/PKGBUILD
deleted file mode 100644
index 4303ad98..00000000
--- a/community/python-recommonmark/PKGBUILD
+++ /dev/null
@@ -1,19 +0,0 @@
-# temporarily, the following tests fail, but we are not interested
-# in nice shiny documentation built on an 32-bit system, we are
-# interested in making software compile using sphinx for docu:
-#FAILED tests/test_sphinx.py::GenericTests::test_code - AssertionError: '<pre>...
-#FAILED tests/test_sphinx.py::GenericTests::test_headings - AssertionError: '<...
-#FAILED tests/test_sphinx.py::GenericTests::test_image - AssertionError: '<p><...
-#FAILED tests/test_sphinx.py::GenericTests::test_links - AssertionError: 'This...
-#FAILED tests/test_sphinx.py::GenericTests::test_lists - AssertionError: '<ol ...
-#FAILED tests/test_sphinx.py::CodeBlockTests::test_integration - AssertionErro...
-#FAILED tests/test_sphinx.py::IndentedCodeTests::test_integration - AssertionE...
-#FAILED tests/test_sphinx.py::NestedHeaderBlock::test_integration - AssertionE...
-#FAILED tests/test_sphinx.py::CustomExtensionTests::test_integration - Asserti...
-eval "$(
- declare -f check | \
- sed '
- s/py.test/py.test || true/
- '
-)"
-
diff --git a/community/python-simplejson/PKGBUILD b/community/python-simplejson/PKGBUILD
new file mode 100644
index 00000000..947b2a88
--- /dev/null
+++ b/community/python-simplejson/PKGBUILD
@@ -0,0 +1,4 @@
+# temporary
+source=('https://github.com/simplejson/simplejson/archive/refs/tags/v3.17.6.tar.gz')
+sha512sums=('48b74388cd3a5cf0acf46a9aa050d628513d842297625f791c7ae07a7c9289afcb0be8d374f77af3bebd50f4c200844bc69f5b77a67220fee357cdfc0d913726')
+
diff --git a/community/python-jinja/PKGBUILD b/community/python-sphinxcontrib-applehelp/PKGBUILD
index 6403c888..6403c888 100644
--- a/community/python-jinja/PKGBUILD
+++ b/community/python-sphinxcontrib-applehelp/PKGBUILD
diff --git a/community/python-sphinx/PKGBUILD b/community/python-sphinxcontrib-devhelp/PKGBUILD
index 6403c888..6403c888 100644
--- a/community/python-sphinx/PKGBUILD
+++ b/community/python-sphinxcontrib-devhelp/PKGBUILD
diff --git a/community/python-more-itertools/PKGBUILD b/community/python-sphinxcontrib-htmlhelp/PKGBUILD
index fcc37cc1..3e723efb 100644
--- a/community/python-more-itertools/PKGBUILD
+++ b/community/python-sphinxcontrib-htmlhelp/PKGBUILD
@@ -1,2 +1,3 @@
-unset checkdepends
+# fails in all tests currently
unset check
+unset checkdepends
diff --git a/community/python-sphinxcontrib-qthelp/PKGBUILD b/community/python-sphinxcontrib-jsmath/PKGBUILD
index 6403c888..6403c888 100644
--- a/community/python-sphinxcontrib-qthelp/PKGBUILD
+++ b/community/python-sphinxcontrib-jsmath/PKGBUILD
diff --git a/community/python-wheel/PKGBUILD b/community/python-wheel/PKGBUILD
deleted file mode 100644
index fcc37cc1..00000000
--- a/community/python-wheel/PKGBUILD
+++ /dev/null
@@ -1,2 +0,0 @@
-unset checkdepends
-unset check
diff --git a/community/python-xarray/PKGBUILD b/community/python-xarray/PKGBUILD
new file mode 100644
index 00000000..97c39ba7
--- /dev/null
+++ b/community/python-xarray/PKGBUILD
@@ -0,0 +1,2 @@
+# scipi tests hang forever and hang build slaves
+unset check
diff --git a/community/reflector/PKGBUILD b/community/reflector/PKGBUILD
index 1c752de0..c3e73ed8 100644
--- a/community/reflector/PKGBUILD
+++ b/community/reflector/PKGBUILD
@@ -1,16 +1,15 @@
source=(
"https://sources.archlinux32.org/sources/reflector32-${pkgver}.tar.gz"{,.sig}
)
-md5sums=('6a7159cbd43b5be0641077caf16ffa45'
+md5sums=('7f6100188a8d8340dcc6d470bbe5e179'
'SKIP')
-sha512sums=('a83d58d36f3dc29763066a0735d2f68c23830b4be0b88d8277a1a98df83631f4ccf98ecea51ba372b983410f367ff71889d42d636ae5dd52ed651aa85e5ec272'
+sha512sums=('9186c66152d20e6c52b7a2f2cd8fb9e5c122f23ec70afc358bfa01dd196a94cb4ae96a7fc8974524ef632e6d591d7889e1128e1c7e0f300562b1372ca61716ed'
'SKIP')
-validpgpkeys=('DE9F7688CACF04FEB81A6C590AEEC90755DA7B5A' '38ACA6A026D25CDD227D24832F6399DCD2212195')
+validpgpkeys=('DE9F7688CACF04FEB81A6C590AEEC90755DA7B5A' '38ACA6A026D25CDD227D24832F6399DCD2212195' '16194A82231E9EF823562181C8E8F5A0AF9BA7E7')
eval "$(
declare -f package | \
sed '
- 2 a ls -lA
s/\$pkgname/${pkgname}32/
'
)"
diff --git a/community/s2n-tls/PKGBUILD b/community/s2n-tls/PKGBUILD
index 523e6247..f96f9937 100644
--- a/community/s2n-tls/PKGBUILD
+++ b/community/s2n-tls/PKGBUILD
@@ -1,3 +1,7 @@
-# see FS32#166
-unset check
-unset checkdepends
+# ignore test results, see FS32#166
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(cmake.*--target.*test.*\)/\1 || true/
+ '
+)"
diff --git a/community/spiped/PKGBUILD b/community/spiped/PKGBUILD
new file mode 100644
index 00000000..191380c4
--- /dev/null
+++ b/community/spiped/PKGBUILD
@@ -0,0 +1,2 @@
+# hangs clients on i486
+unset check
diff --git a/community/tinyemu/PKGBUILD b/community/tinyemu/PKGBUILD
new file mode 100644
index 00000000..b7af84e1
--- /dev/null
+++ b/community/tinyemu/PKGBUILD
@@ -0,0 +1,11 @@
+# disable 128 bit RISCV on 32-bit targets, not supported
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i sed -i s/^CONFIG_INT128=.*/#CONFIG_INT128=n/ "$m"
+ '
+)"
+
diff --git a/community/ttf-ibm-plex/PKGBUILD b/community/ttf-ibm-plex/PKGBUILD
deleted file mode 100644
index 5c3ebc43..00000000
--- a/community/ttf-ibm-plex/PKGBUILD
+++ /dev/null
@@ -1,2 +0,0 @@
-# workaround for FS#65585 (sits there idle since Feb 2020)
-sha256sums=('6ee1073ce3568de2b537a44c556f436020eea42b05864be0c4ed2e9c81ba099c')
diff --git a/community/xrootd4/PKGBUILD b/community/xrootd4/PKGBUILD
deleted file mode 100644
index 9de19a3b..00000000
--- a/community/xrootd4/PKGBUILD
+++ /dev/null
@@ -1,2 +0,0 @@
-# no CEPH
-depends=(${depends[@]//ceph/})