summaryrefslogtreecommitdiff
path: root/community/python-matplotlib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-matplotlib/PKGBUILD')
-rw-r--r--community/python-matplotlib/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/python-matplotlib/PKGBUILD b/community/python-matplotlib/PKGBUILD
index 7248998d..8103ed2a 100644
--- a/community/python-matplotlib/PKGBUILD
+++ b/community/python-matplotlib/PKGBUILD
@@ -1,2 +1,14 @@
+checkdepends=(${makedepends[@]//pyside2/})
+checkdepends_i686+=(pyside2)
+checkdepends_pentium4=("${checkdepends_i686[@]}")
+
+checkdepends=(${makedepends[@]//python-pyqt6/})
+checkdepends_i686+=(python-pyqt6)
+checkdepends_pentium4=("${checkdepends_i686[@]}")
+
+checkdepends=(${makedepends[@]//pyside6/})
+checkdepends_i686+=(pyside6)
+checkdepends_pentium4=("${checkdepends_i686[@]}")
+
# tests fails in various ways
unset check